1

I was curious about containers, so decided to give it a try. Prepared a server as host with a fresh install of CentOS 7, installed lxc and lxc-templates and configured a bridge interface.

I've created a centos container, everything worked fine, except for one strange behaviour: yum installed 7 packages and halted at the 8th one without error, just keeps saying Installing forever. Tried using --verbose and -d9 options, still no error, not even in the yum, dmesg and messages logs

This bug isn't present on debian containers. Does anyone have an idea or has the same issue?

Edit: if I cancel the current yum installation and run yum-complete-transaction the installation finishes without problem. Unless there's a pending count of more than 7 packages to install, in that case I have to cancel the task and run again. Always stops after the 7th package.

2
  • Have you run this in one session, then watched your disk space in another session while it installs? Could it be that lxc is deploying files under /var and filling up the disk? – Aaron Jan 21 '16 at 16:53
  • Nope @Aaron, I just have /boot /home and / partitions, currently root has 27GB of available space. – user202937 Jan 21 '16 at 17:20
0

It's a LXC 1.0.11 bug on CentOS 7. When I create a Linux Container on Fedora 27 with LXC 2.0.9, I've got no bug.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.