0

I tried to login to my remote CentOS server using my private key and I was surprised to get this message :

There were 29031 failed login attempts since the last successful login.

After that it asks me to change my password, which requires my current password, which I can't provide because I'm fairly sure I've never set one. It won't let me log in until I've changed the password. How can I get around this?

5
  • What is your question?
    – MadHatter
    Jan 21 '16 at 16:22
  • It asks me to enter the current password to change it , when i dont have any current password and my private key is set at the begin , well how can i access the server ? thnx
    – Linuxer
    Jan 21 '16 at 16:28
  • Has the sysadmin looked at the logs on the server? If so, what is in the logs?
    – Aaron
    Jan 21 '16 at 16:30
  • OK, I've tried to clarify the question based on your reply - does that look right? If so, and it's your server, do you have out-of-band console access of any kind?
    – MadHatter
    Jan 21 '16 at 16:55
  • Is this the first time you are trying to log in on the server? Are you trying to log in as root or some other user? How do you usually run commands as root on the server? What exactly does the output say? (Please copy-paste the output such that we can see the message about failed logins and the request to change password in context). Which provider is this? (It does sound like the change password thing might be provider specific.)
    – kasperd
    Jan 29 '16 at 22:13
1

The fact that your are using Putty and private keys is not related to the fact that your Unix account has a password. If you don't know / don't remember your password, you will almost definitely need your sys admin to reset it for you.

2
  • i was asked to generate a key pair at first by my host company , i never set a password only working with private and public keys ! thnx
    – Linuxer
    Jan 21 '16 at 16:11
  • @Linuxer Someone set a password on your account! If it was not you, then you really need to be talking to whoever runs the server. Jan 21 '16 at 18:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.