1

I have a HP ProLiant DL160 G6 with a P410 1GB FBWC controller. I have 4 x 4TB SATA drives. When an array has been created, I can start the Windows Server 2008 R2 installation, and it goes fine until the first reboot. It then hangs on the green loading bar screen perpetually.

Summary of what I have tried:

  • Updated System ROM and P410 firmware to latest.
  • Started the install from HP EasySetup (both 2.00b and the newest version). This fails and complains of a missing file hpssbem.exe IIRC.
  • Tried Windows Server 2012 R2 install instead. This fails complaining of corrupt media? (Surely impossible - it's an MD5 checked ISO freshly downloaded to a USB media)
  • Checked the MD5 of the Server 2008 R2 media.
  • Tried different Server 2008 R2 media, including USB media and a DVD.
  • Performed the HP Insight diagnostics. No errors or faults found.

I've spent two days on this and have no hair left. Any ideas?

  • Have you updated firmware on your RAID controller? Is this a completely new installation? What was running on the server before this? – ewwhite Jan 21 '16 at 20:44
  • Yes - updated to latest on the HPE website. It's several year old hardware, but up until a few days ago it's been running Ubuntu. And yes, completely new installation. It completes the install from USB/DVD media, but it won't get past the loading screen on first boot from the HD. – George Jan 21 '16 at 20:54
  • How large is the logical drive you're installing to (on the P410 controller)? – ewwhite Jan 21 '16 at 20:55
  • I've tried a variety. Obviously Server 2k8r2 has a 2TB MBR limit, so I have tried with a 100GB or so Logical disk configured from ACU. Have also tried with a single 8TB RAID1+0 logical disk partitioned as 2TB in Windows setup. Again, to no avail. – George Jan 21 '16 at 21:00
  • Well, you should be installing to the smaller Logical Drive. I'd probably reset the BIOS settings to default, but outside of that, I'm not sure what the issue is. – ewwhite Jan 21 '16 at 21:01
1

Finally worked out the problem inadvertedly whilst installing ESXi instead and receiving an error regarding the partition tables.

Solution: run gPartEd and manually init an MBR on the small logical disk and a GPT on the larger disk.

ESXi installed then which led me to try Windows on bare metal again, and like clock work, it booted fine after install. You would think that Microsoft would correctly set up the partition tables on a new install...or perhaps it is a weird oddity after configuring arrays with the HP SSA.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.