1

So I have a server collecting metrics via StatsD, which get aggregated and shown via the Graphite webapp.

If I mark the Auto-Refresh option in my chart, the time doesn't match with the time I'm on. I'm in Hong Kong and it's 5:20PM now, and the server where the Graphite instance is, reports 4:20AM via the date command. However, the Graphite chart shows it's 3:20!

So I'm a bit puzzled on what's the proper way to fix this. The server is a DigitalOcean service that is apparently located in Singapore (same timezone as Hong Kong), but something tells me that this information should be irrelevant, right? I mean, Graphite should show me the correct time just depending on the timezone of the user of its WebUI, right?

How to fix this properly? Set the time in the server with root privileges, or adjust the TIME_ZONE setting in Graphite? Or something else?

0

Graphite should show you the correct time not just depending on the WebUI user timezone. Note that Graphite_TZ - User_TZ offset is needed to calculate the right time to show. That means Graphite_TZ must be also properly set.

Looking the 14h offset it seems too me you are running the default Graphite timezone settings (America/Chicago). It would be enough to fix it.

In general, to configure OS TZ isn't a must, but a good practice. So, I would recommend you to configure also OS TimeZone to match Graphite TZ settings in order to avoid messing with time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.