0

I have created a group policy which should map the network folder \\SHARED\data to drive letter H:. The policy is applied if I run gpupdate /force, but when I restart the computer and login, the policy is not applied (the drive is not mapped).

I have read through the page here: http://techibee.com/group-policies/all-about-drive-mapping-in-group-policy-preferences/202

which states:

1. Edit the GPO which is applicable to your computers and navigate to [Computer Configuration | Policies | Administrative Templates | System | Group Policy]
2. Now go the properties of “Drive maps preference extension policy processing” policy and enable the option “Process even if the Group Policy objects have not changed”
3. Save you GPO and reboot your machine

However, under my Computer Configuration | Policies | Administrative Templates folder, there are no sub-folders, just an All Settings item which doesn't contain anything at all.

I then tried to re-register the Administrative Templates snap-in by running regsvr32 gptext.dll, but that didn't change anything.

We are running Windows Server 2008 Standard as our domain controller.

EDIT

I have found more information here: http://social.technet.microsoft.com/wiki/contents/articles/12221.troubleshooting-the-drive-maps-preference-extension-in-group-policy-replace-mode-only-maps-the-drive-every-other-logon.aspx?wa=wsignin1.0

Where one of the suggested solutions is:

2 - Set Group Policy to always run synchronously

It is the need to first signal Group Policy to run synchronously on the next logon that is causing the Drive Maps preference extension to reapply settings every other logon.

Instead, you can set the “Always wait for the network at computer startup and logon” policy setting. This can be found at:

Computer Configuration\Policies\Administrative Templates\System\Logon

If you enable this policy setting, client computers wait for the network to be fully initialized before users are logged on. Group Policy is applied in the foreground synchronously.

By enabling this policy setting, every user logon will be processed synchronously. The Drive Maps preference extension will determine every logon to be synchronous and therefore process the drive map preference settings every logon.

The down side to this change in behavior is that it takes more time to restart the computer and logon to the computer when Group Policy processes synchronously. The trade-off becomes choosing consistent behavior or slower logon times.

If the concern is making sure that the drives stay mapped as opposed to making sure the drive maps are not overwritten during the user session, a potential solution could be to use the reconnect option with the Drive Maps preference item.

However, I still run into the problem of not having any items in my Administrative Templates, so I am unable to change the suggested setting.

The drive does map after a second login. Just not on the first login after a reboot. It sounds like the above solution would work for me, I just need to be able to get to the System\Logon section of the Administrative Templates..

  • Why are you trying to map this drive under the computer context? – joeqwerty Jan 26 '16 at 23:40
  • I'm not. That is just where it recommended to change the "drive maps preference extension policy" setting. The policy is linked to the domain users, and is User Configuration | Preferences | Windows Settings | Drive Maps – dub stylee Jan 26 '16 at 23:42
  • OK, my bad. I misunderstood what you wrote. – joeqwerty Jan 26 '16 at 23:44
  • No problem. It just seems like something is missing in my Administrative Templates snap-in. I assume it has something to do with it trying to map the drive before the network connection is ready, so the drive is not accessible. It runs fine if I run gpupdate /force after I am logged in. – dub stylee Jan 26 '16 at 23:45
  • It also appears that if I just wait about 10-15 seconds after reboot before logging on, the policy works as well. However, I need to be able to ensure that the login waits for the network so that this policy is always applied. – dub stylee Jan 27 '16 at 0:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.