I'm IT Technician at a Secondary School and our Network Manager is away on long term leave. Currently our student's aren't able to send to - compressed folder. When trying the error 'File not found or no read permission' appears. It works for staff so I can only imagine it's a group policy setting. I have minimal knowledge on GPOs. My understanding is temp files are used on the C: drive when creating zip folders, and I've tried giving a test student full access to these but this didn't work. Third party (7-zip) also doesn't work.

Windows 7 with mix of 64/32 used. Server 2008 R2 Enterprise.

Any help massively appreciated!

  • Try to make sure the folder(s) to be zipped names are not too long. I just tried to compress a folder with 48 characters including spaces and it wouldn't go. Only after I paired it down to 34 did it work. Cheers Aug 28, 2017 at 13:12

8 Answers 8


I had files locked in the folder.

Once I closed the programs that had the file locked, I could create a zip file successfully.


Make sure that they have access to the temp folder (I know, you said you tried the C drive, but please double check); this error message usually means that zip fails because they don't. Also, the temp folder in question might not be c:\temp. Check in Computer Properties/System Information -> Advanced System Settings -> Advanced -> Environment variables. (Mine is %USERPROFILE%\AppData\Local\Temp.) The students need access to that temp folder.

Good luck!

  • Thanks - I double checked and user definitely has permissions on the temp folder. Another thing of interest is the users can't actually see the C drive. I'm sure its a GPO issue but can't see an option for it anywhere...
    – Scott Gunn
    Jan 28, 2016 at 9:44
  • The "hide drives" group policy object is in User Configuration -> Administrative Templates -> Windows Components -> Windows Explorer. Jan 28, 2016 at 15:30
  • I changed the TMP and TEMP variables to %USERPROFILE%\AppData\Local\Temp from C:\Windows\Temp now I can compress, but every application complains that they cannot create temporary files... :D
    – inf3rno
    Feb 8, 2017 at 1:31

I came across a very similar issue in Windows 10 regarding being able to zip a .sql file. The message I received was "file not found or no read permissions". I tried adjusting the security and permissions on the file and moving it to a different drive/folder but nothing changed. What I did notice, however, is that this particular file did not have a "date modified" value. So, I opened the file in Code Writer, added a space to the end of the file, and then saved it. This created a "date modified" value and thus I was able to zip the file. I suspect that some other application had a lock of some kind on the file.


Similar to ShadeTreeAdmin, but with Daylight Savings Time "fall behind" added in: if you have a "stripped out" time stamp such as from a network file copy, it seems that old MS-DOS roots assign a datestamp of Jan 1, 1980 at midnight. If you do that during daylight savings time (e.g., June) and then later try to put the file into a zip using the compressed folder menu item when DST is over (e.g., December), the date stamp moves to Dec 31, 1979 at 11:00 pm ... and you get the same error as this thread is discussing. Touching the file to give it a real timestamp for each file to be put into the compressed folder, or doing a minor edit (like add a space, save, etc.), works around the problem.


Are your students able to send other kind of files? Are the zip files closed before sending ? Have you tried moving the zip file somewhere else before sending ? ex: on the Desktop where they should have enough rights by default.

We have a policy that prevents from sending .exe or .bat files and to overcome it we rename them .gfe (like Good For Email) before sending them.

Can you try this and tell me ?

Hope it helps.

  • maxsnet - Thanks for the reply but sorry I think you've misunderstood - the students aren't able to create a zip folder by either right click - send to - compressed or by creating a new zip folder in Explorer (right click - new - compressed). Our students don't have rights to do anything on the desktop. Sorry about the confusion I've now edited the original question.
    – Scott Gunn
    Jan 27, 2016 at 11:33

You should use process monitor to see what happens exactly when the problem occurs: https://technet.microsoft.com/en-us/sysinternals/processmonitor.aspx


If a locked down temp folder is the issue you can tell 7-zip to use a different temp folder. The temp folder can also be changed in the Environmental Variable settings to a location where you have more permissions.


I had to close the file that I had open. Then I tried zipping it again, and it worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .