1

I've just deployed a new VM on Microsoft Azure with Windows Server 2012 R2. It is identical to other two I have (it was created from scratch though, not duplicated or from an pre-existing image), all of which I have performed the same steps:

  1. Update Windows the first time I login and after every new application install;
  2. Set up roles and features (Web Server (IIS) with ASP.NET 3.5 and 4.5, HTTP, TCP, Pipe activation, etc...);
  3. Install Visual Studio 2015 Enterprise;
  4. Install MySQL Server Community Edition x64.

And it have always worked. However, on this new machine, MySQL Server x64 setup fails when trying to start the service (running mysqld.exe) with error 0xc000007b Application was unable to start correctly. This is the event log:

Faulting application name: mysqld.exe, version: 5.7.10.0, time stamp: 0x565c1007
Faulting module name: ntdll.dll, version: 6.3.9600.18185, time stamp: 0x5683f0c5
Exception code: 0xc000007b
Fault offset: 0x00000000000ec580
Faulting process id: 0xff0
Faulting application start time: 0x01d15a15d089c300
Faulting application path: C:\Program Files\MySQL\MySQL Server 5.7\bin\mysqld.exe
Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
Report Id: 0f00893d-c609-11e5-80c7-000d3a0108af
Faulting package full name: 
Faulting package-relative application ID: 

Trying to run mysqld.exe manually results in the same error. I've tried to reinstall it many times with no success. However, the 32bit version installs, runs and works normally.

1

0xc000007b decodes to:

# for hex 0xc000007b / decimal -1073741701
  STATUS_INVALID_IMAGE_FORMAT                                    ntstatus.h
# {Bad Image}
# %hs is either not designed to run on Windows or it contains
# an error. Try installing the program again using the
# original installation media or contact your system
# administrator or the software vendor for support.

this Bad Image would prompt me to ask to go to the 32-bit version which you already (successfully) did.

Either test your installer binary on a (known-good) 64-bit host, or download a new installer.

  • I was using the web installer. I tried downloading the full installer, but got the same error. I'll try running it on a new vm now. – andre_ss6 Jan 29 '16 at 14:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.