1

I've been having troubles installing updates lately. Updating via the Software Updater gave no list of packages, though it still said it had to download ~100MB worth of updates. The update failed as apparently I might have broken packages or unmet dependencies.

I tried to search for broken packages in Synaptic, but there were none. I updated manually (still via Synaptic) all the packages I could, and narrowed down 4 packages that seem to be causing some troubles (see below). Now, the Software Updater crashes while checking for updates (before even giving me any list of updates).

Here's the result of apt-get update && apt-get upgrade :

The following packages have been kept back:
gcc-4.9-base gcc-4.9-base:i386 libgcc1 libgcc1:i386
0 to upgrade, 0 to newly install, 0 to remove and 4 not to upgrade.

When I try to remove them manually, I get a long list of packages that are to be uninstalled (basically all of them).

For exemple,

apt-get remove gcc-4.9-base

gives (without the full list of packages) :

The following NEW packages will be installed
multiarch-support:i386
The following packages will be upgraded:
gcc-4.9-base:i386 libgcc1:i386
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
apt libapt-pkg4.12 (due to apt) libc6 (due to apt) libgcc1 (due to apt)
libstdc++6 (due to apt) gnupg (due to apt) base-files base-passwd
libdebconfclient0 (due to base-passwd) bash debianutils (due to bash) dash
(due to bash) libtinfo5 (due to bash) bsdutils coreutils libacl1 (due to
coreutils) libattr1 (due to coreutils) libselinux1 (due to coreutils) dpkg
(due to dash) diffutils libbz2-1.0 (due to dpkg) liblzma5 (due to dpkg)
zlib1g (due to dpkg) tar (due to dpkg) e2fsprogs e2fslibs (due to e2fsprogs)
libblkid1 (due to e2fsprogs) libcomerr2 (due to e2fsprogs) libss2 (due to
e2fsprogs) libuuid1 (due to e2fsprogs) util-linux (due to e2fsprogs)
findutils grep install-info (due to grep) libpcre3 (due to grep) gzip
hostname libc-bin libcap2 (due to libc-bin) login libpam0g (due to login)
libpam-runtime (due to login) libpam-modules (due to login) mount libmount1
(due to mount) ncurses-bin perl-base sed tzdata (due to util-linux) debconf
(due to util-linux) sysv-rc (due to util-linux) libncurses5 (due to
util-linux) libslang2 (due to util-linux)
2 to upgrade, 1 to newly install, 2477 to remove and 0 not to upgrade.
Need to get 67,6 kB of archives.
After this operation, 10,3 GB disk space will be freed.
You are about to do something potentially harmful
To continue type in the phrase ‘Yes, do as I say!’

To which I obviously responded : Oh god please don't do this !

I found a topic (here) where someone reports a similar issue, however the solutions suggested won't work.

Any idea on how to solve this is welcomed, I'm available if you need more info/terminal results to better assess the situation. Thanks in advance !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.