I am in the process of upgrading a Web Server from Windows 2003/IIS6 to Windows 2012/IIS8.5. So far so good, except for one thing. I have a Web Service that works on the original server, but when I configure it in W12/IIS8.5, every request is resulting in a 401.2.5 response code.

I have googled that response code extensively, but, all I've found is pages me that it means the web server is not configured correctly. I can't figure out what's wrong.

I configured by doing the following:

  1. Add the CLIENT CERTIFICATE CA ROOT CERTIFICATE (Verisign Class 3 Secure Server - G3) to the Trusted Root Certification Authorities in mmc.
  2. Create a Windows User Account, remove it from Users, deny it Log on Locally.
  3. Update security on the Windows Web Service directory to Deny access to the IIS and IIS Application Pool user accounts, and Allow access to the new User Account.
  4. Disable all authentication methods on the directory in IIS.
  5. Require SSL and Client Certificates on the directory in IIS.
  6. Map the client's certificate to the User Account in IIS by using the Configuration Editor to add the system.webServer.security.authentication.iisClientCertificateAuthentication option using the User Account that I created for this purpose (step 1).
  7. Adding an Authorization rule for the Web Service directory to only allow the specified User Account.
  8. Granting access to IIS Users to the web.config file in the Windows Web Service directory.
  9. Restarting IIS.

Any ideas what could be causing the 401.2.5 response?

I tried adding a system.webServer.security.authorization configuration for the directory, but this had no effect.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.