1

I'm trying to start using Homestead for my non-Laravel projects (legacy) and I managed to install box 0.3.3 successfully by cloning laravel/homestead 2.2.1 (with PHP 5.6.15).

Now my problem is due to .htaccess configuration. The one I use works for Apache, but is giving me No input file specified in Nginx (at Homestead).

The .htaccess I'm using is as follow. The goal is

  • allow browser to load/download some specific extension
  • disallow any load/download for specific folders (config and email)
  • Redirect to index.php
RewriteEngine on
RewriteRule !\.(ini|js|ico|gif|jpg|png|css|html|swf|flv|xml|csv)|^[config/*|email/*]$ index.php

I tried online tools to convert like Anilcetin and winginx with no luck.

In my server, I'm suppose to load URLs like /user/panel and /user/manager/shop and the index.php file knows how to read that from the URL and load the correct page.

  • That bit of .htaccess is redundant. Just drop it. Your try_files will send everything to index.php. – Michael Hampton Feb 7 '16 at 0:19
  • @MichaelHampton you seem to be absolutely right. I removed the htaccess completely and I'm getting the same error No input file specified. – Marco Aurélio Deleu Feb 7 '16 at 0:57
  • That's a completely different issue than the one you've asked about. Consider posting a new question. – Michael Hampton Feb 7 '16 at 1:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.