0

I want to disable shadow copies being created on a specific Windows NFS share folder which is being used by an ESXi 6 server for virtual machine backups (via xsibackup). The reason for wanting to do this is because the VM backups are being handled by xsibackup with full and incremental backups being done daily via xsibackup and xsibackup-rsync. The shadow copies generated for this NFS share are using a lot of space on my disk array and are not really required in this case.

I would like to be able to disable the NFS share from being shadow copied while keeping the main shadow copy process unaffected for the rest of the volume the NFS share is on. I'd also like to be able to delete the shadow copies already created for the NFS share folder to reclaim the disk space.

I'm aware of this KB, but it doesn't appear to be working. I tried creating a new multi string REG_MULTI_SZ in HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\BackupRestore\FilesNotToSnapshot called it "ESXi NFS Share" and set the value to E:\NFS FOLDER NAME\*.* /s

https://msdn.microsoft.com/en-us/library/aa819132%28v=vs.85%29.aspx

What is the best approach to provide exclusion rules for shadow copies and delete already created copies if possible?

1

I might be taken your question out of context here since I haven't done you described. My understanding is that you're trying to disable VSS on specific NFS share while it backup certain one that are selected. It shows that 2008 doesn't allow that type of config, it only allows per volume basis. Maybe you might want to consider mounting it on a different volume instead?
Best Practices for Shadow Copies of Shared Folders

You can only enable Shadow Copies of Shared Folders on a per-volume basis—that is, you cannot select specific shared folders and files on a volume to be copied or not copied.
Enable and Configure Shadow Copies of Shared Folders

| improve this answer | |
  • So essentially, a NFS share sits on a large Windows storage space along with various other shares (not NFS). Shadow Copies are configured at the volume level so the whole of the E:/ drive gets snapshot twice daily. I ideally want to exclude the NFS share from the snapshot process completely, as they are hundreds of gigabytes in size per snapshot. – James White Feb 9 '16 at 21:03
  • In theory I could create a new storage space to ultimately have a separate volume e.g. F:/ and not have shadow copies enabled. Problem is, in order for Server 2012 R2 Essentials Server backup to work, I think it enables shadow copies automatically when configured in the dashboard. I'd still want this volume that holds the NFS share to be backed up for redundancy. – James White Feb 9 '16 at 21:36
  • In the end, I ended up following your advice. I created a new volume by creating a two-way mirror space (As I'm using storage spaces) and hosted the NFS share there. After setting up the new volume in my Server Backup, I disabled shadow copies and the schedule to ensure the F:/ volume doesn't ever generate shadow copies. I then deleted shadow copies where the massive inflation of disk space started happening on the other volume. This resolved the problem and brought down the used space after running disk optimizer. – James White Feb 12 '16 at 12:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.