0

I've been running some VMs in VirtualBox and cannot get Kerberos5 installed.

I keep receiving the error:

Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: krb5-kdc : Depends: krb5-config but it is not installable Depends: krb5-user but it is not going to be installed E: Unable to correct problems, you have held broken packages.

I have this problem on fresh installs of Debian 8.2 and 8.3, any thoughts?

EDIT

Sources:

deb cdrom:[Debian GNU/Linux 8.3.0 Jessie - Official amd64 DVD Binary-1 20160123-19:03]/ jessie contrib main deb cdrom:[Debian GNU/Linux 8.3.0 Jessie - Official amd64 DVD Binary-1 20160123-19:03]/ jessie contrib main deb http://security.debian.org/ jessie/updates main contrib deb-src http://security.debian.org/ jessie/updates main contrib

there are no files in sources.list.d directory

Policies:

$ apt-cache policy krb5-kdc krb5-kdc: Installed: (none) Candidate: 1.12.1+dfsg-19+deb8u2 Version table: 1.12.1+dfsg-19+deb8u2 0 500 http://security.debian.org/ jessie/updates/main amd64 Packages

$ apt-cache policy krb5-config krb5-config: Installed: (none) Candidate: (none) Version table:

$ apt-cache policy krb5-user krb5-user: Installed: (none) Candidate: 1.12.1+dfsg-19+deb8u2 Version table: 1.12.1+dfsg-19+deb8u2 0 500 http://security.debian.org/ jessie/updates/main amd64 Packages

I tried installing on the clean install, after installing the necessary items (sudo etc) I've done a sudo apt-get update, tried Kerberos I've gone through Synaptic to install all the dependencies which were listed as: Depends: libgssrpc4 but it is not going to be installed Depends: libkadm5clnt-mit9 but it is not going to be installed Depends: libkadm5srv-mit9 but it is not going to be installed Depends: libkdb5-7 but it is not going to be installed Depends: libverto1 but it is not going to be installed Depends: krb5-config but it is not installable Depends: krb5-user but it is not going to be installed Depends: libverto-libev1 but it is not going to be installed or libverto-libevent1 but it is not installable

krb5-config and krb5-user files would not install at any stage.

hope that helps!

  • Please show your /etc/apt/sources.list and the contents of any files in /etc/apt/sources.list.d. Also: Please show the output of apt-cache policy {krb5-kdc|krb5-config|krb5-user}, that is, apt-cache policy <pkg> for each of the listed packages. Besides: Did you do anything yourself to try to solve this problem? – gf_ Feb 10 '16 at 8:49
  • sorry for the late reply, have edited the original post with the requested info – tokyotech Feb 12 '16 at 1:03
1

According to the content you've provided of your sources.list file, you're missing entries, that's why the install fails.

  • Add this:

    deb http://httpredir.debian.org/debian jessie main
    deb-src http://httpredir.debian.org/debian jessie main
    
    deb http://httpredir.debian.org/debian jessie-updates main
    deb-src http://httpredir.debian.org/debian jessie-updates main
    
  • run apt-get update and try to do the install again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.