3

I have a build server on linode which several of my google compute engine instances pull from. I've not changed any configuration, but as of today I'm no longer able to connect to my compute instances from that server. All traffic on all ports between the two seems to be blocked.

Any ideas for how to diagnose and fix this? Any chance google just blocked my external server IP? I'm able to connect from other linode servers with the same configurations just fine.

I tried following the instructions here: https://cloud.google.com/compute/docs/troubleshooting#ssherrors. The firewall rules are fine and allow ssh as well as web traffic. the nc [my ip] 22 command just times out though, and creating a new instance and doing gcloud compute ssh temp-machine times out also.

I'm at a loss as to what's going on. Everything was working and nothing changed as far as our configurations, but suddenly all traffic between the two servers seems to be blocked. Any help would be greatly appreciated!

Update

My Google Firewall rules are pretty open, as follows:

NAME                   NETWORK SRC_RANGES    RULES                        SRC_TAGS TARGET_TAGS
allow-ftp              default 0.0.0.0/0     tcp:21,tcp:60000-60100
default-allow-http     default 0.0.0.0/0     tcp:80                                http-server
default-allow-https    default 0.0.0.0/0     tcp:443                               https-server
default-allow-icmp     default 0.0.0.0/0     icmp
default-allow-internal default 10.240.0.0/16 tcp:0-65535,udp:0-65535,icmp
default-allow-ssh      default 0.0.0.0/0     tcp:22

Update 2

Google appears to have blacklisted a large pool of IP addresses assigned by Linode blocking traffic between our client's websites and our software on compute engine. On one of my linodes, I kept requesting a new IP address and finally got one that works fine, which to me verifies that it's nothing in my setup but rather something on Google's end. Being new to GCP this year, this is quite concerning, especially without being able to contact them unless we pay an additional $150/month. Contacting Linode to see if there's anything they can do on their end.

  • Have you tried connecting in the opposite way? What happens when you ping in either direction? What are yoour Google Firewall rules? – Adrian Todorov Feb 10 '16 at 21:39
  • @AdrianTodorov, Thanks for responding! I've tried connecting both directions and it times out either way. It appears to be blocked on the google side though, because if I run traceroute to my GCE instance from my external server, and it bounces around a few IP addresses before landing on a google IP address and timing out. Tracing from my GCE instance just immediately times out all requests without getting anywhere. I've updated my question with my google firewall rules. – RLHawk Feb 10 '16 at 22:08
  • 1
    We posted an answer to your question on this thread: groups.google.com/forum/#!msg/gce-discussion/Z5zc06Zo2Zo/… – Kamran Feb 12 '16 at 0:26
2

Posting an answer for community members who may be seeing the same issue.

The issue was related to Linode IPs been blocked for being geo-located to a T6 region. This issue already has been resolved, more information can be found on this GCE discussion thread.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.