0

All

We have a server with an Intel S5520HC motherboard, two E5620 processors, 6x2GB memory modules and four 1TB hard drives in RAID 10 connected directly to the board. I'm trying to be as detailed as possible in case any of this connects.

When it was purchased (before I got there), it had a PCI (consumer grade!) gigabit Ethernet card installed, and when this failed, my testing of the onboard NICs revealed that they didn't work. At all. It had PCI identifier 8086:10AA which has been discussed at length previously.

Armed with this knowledge, I picked up an Intel PRO/1000 PT quad-port adapter and installed it into this system. Imagine my disdain when it didn't even appear! For science, I installed a PRO/1000 CT desktop adapter, which worked.

Ok, says I, I've got an R/S quad-port NIC. Before I called the vendor to rant and rave at them, I decided to science some more. I installed the card into a Dell PowerEdge 1950 I had lying around, expecting to see the same behaviour. Nope - the card worked perfectly, even in the pre-install environment of a Windows Server 2008 R2 install CD.

So what's going on here? Sure, I could put the lack of action on the on-board NICs down to dodgy EEPROMs (as stated in the links above), but why would it also affect an enterprise-grade quad-port card?

1

So you have a motherboard with:

  • dead onboard NICS
  • consumer-grade NIC in a PCI(e?) slot that died
  • a Intel PRO1000/PT nic that won't work in any of the PCI(e?) slots

And all these NICS work just fine in an old PowerEdge 1950.

I'm pretty confident that your motherboard is toasted. I advise you to get a new, prebuilt server from Dell/HP/Lenovo and stop wasting time weird issues like these. It's not worth it in the long run.

  • Yeah, I know. Sadly it's not in the budget to buy a whole new server right now, I'll try to get one in for the next budget. – Aaron Mason Feb 24 '16 at 1:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.