1

I'm using Exchange 2013 in our environment and I am doing a test for a user with emails older than 5 years in their mailbox. I used the following PS command:

Enable-Mailbox "Username" -Archive -ArchiveDatabase "ExistingDatabaseName" The database is separate from the one their normal user account is on.

The archive command appears to have worked as they now see an "archive" folder on the bottom of OWA and a "Online Archive - username@domain.com" mailbox in their Outlook client.

The problem is that there is no data in this folder. I'm assuming there's something I'm supposed to do with retention tags/policies (currently all users are on the default MRM policy). I thought the default was to move everything older than 2 years to the archive mailbox.

Any ideas on how to troubleshoot and resolve this issue?

Edit: Verified user is listed with "Default MRM Policy", There is a "Default 2 year move to archive" rule with type "Default" and retention period of 730 days and action of "archive" in that policy. along with a number of personal rule options as well.

  • First thing, double-check that you have put your test user on a retention policy, and verified the settings in that policy. Don't assume anything; so verify those things and update your question with the results. – mfinni Feb 11 '16 at 17:05
  • @mfinni The user is listed with "Default MRM Policy", There is a "Default 2 year move to archive" rule with type "Default" and retention period of 730 days and action of "archive". I'll update the question accordingly – Abraxas Feb 11 '16 at 17:11
  • 1
    How much time has passed since you enabled this setting for the user? If it's been less than a day, the Managed Folder Assistant may not have run on their mailbox yet. Have you forced it to run? If not, do so - any maybe turn up the logging level to see if something unexpected is happening. – mfinni Feb 11 '16 at 18:47
1

My answer is that you probably haven't had a run of the Managed Folder Assistant yet. You can force it to run if you need to.

  • 1
    Thanks! Your mostly right, that hasn't happened yet but it was also the case that the use had an auto archive rule for messages older than one year running too....so nothing hit the 2 year threshold lol – Abraxas Feb 25 '16 at 22:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.