1

I'm running Windows 10 as guest via KVM / qemu. Unfortunately, Windows doesn't recognize the fedora virtio drivers I want to install for better HDD perfomance. The driver itself does show up, but installing it fails:

Qemu screenshot - "No new device drivers found"

I tried several driver versions, namely 0.1.102, 0.1.110 and 0.1.112, all for amd64.

Commandline options:

sudo qemu-system-x86_64 \
-device virtio-scsi-pci \
-drive if=none,id=hd,file=win.img,format=raw -device scsi-hd,drive=hd \
--enable-kvm \
-cdrom Win10_1511_German_x64.iso \
-m 4048 \
-drive file=$HOME/VirtualMachines/virtio-win-0.1.112.iso,id=driveriso,if=none,format=raw \
-device ide-cd,bus=ide.1,drive=driveriso \
-cpu host,kvm=off

What could cause Win 10 to reject those drivers? Are there better alternatives for fast HDD access from the Guest OS?

Host OS:

  • CPU: i7-6700k
  • OS: Ubuntu 15.10
  • uname -r: 4.3.4-040304-generic
  • uname -m: x86_64
  • qemu-system-x86_64 --version: QEMU emulator version 2.3.0 (Debian 1:2.3+dfsg-5ubuntu9.2)
  • I recommend strongly that you use virt-manager or virt-install with libvirtd to create VMs. Doing it manually can only result in trouble. – Michael Hampton Mar 2 '18 at 21:40
1

I had the similar problem when I tried to install Windows guest for KVM/qemu (on Ubuntu 14.04) using Packer.

I used stable virtio drivers from Fedora but the installation failed with the same error mesage. Then I found a workaround: when I changed storage type to IDE it worked.

After that I found and tried latest (not stable) drivers on Fedora website and the installation was successful.

0

I had a similar problem and i ended using ide-hd to install the driver once installed I changed it back to scsi-hd and it works fine :D

not sure why you have --enable-kvm and then you have -cpu host,kvm=off this is contracting and I believe qemu will use the last options passed.

sudo qemu-system-x86_64 \
-device virtio-scsi-pci,id=scsidev \
-drive if=none,id=hd,file=win.img,format=raw -device ide-hd,drive=hd \
--enable-kvm \
-cdrom Win10_1511_German_x64.iso \
-m 4048 \
-drive file=$HOME/VirtualMachines/virtio-win-0.1.112.iso,id=driveriso,if=none,format=raw \
-device ide-cd,bus=ide.1,drive=driveriso \
-cpu host,kvm=off

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.