0

Windows Server Standard FE (2008) - Service Pack 2 (SBS) Exchange 2007 (08.01.0436.000) - Version 8.1 (Build 2406)

(Tried to find the Service Pack version, but the only way that I can see to do this is to use the Shell, which does not work).

Nothing in the Event Viewer.

Whether using the Start Menu shortcut or loading the snap-in manually from PowerShell, I get the same error message:

C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -PSConsoleFile "C:\Program Files\Microsoft\Exchange Server\bin\exshell.psc1" -noexit -command ". 'C:\Program Files\Microsoft\Exchange Server\bin\Exchange.ps1'"

WARNING: The following errors occurred when loading console C:\Program Files\Microsoft\ExchangeServer\bin\exshell.psc1:

Cannot load Windows PowerShell Snap-In Microsoft.Exchange.Management.PowerShell.Admin because of the following error:

Unable to cast object of type 'Microsoft.Exchange.Management.PowerShell.AdminPSSnapIn' to type 'System.Management.Automation.CustomPSSnapIn'.

Command '. 'C:\Program Files\Microsoft\Exchange Server\bin\Exchange.ps1'' could not be run because some Windows PowerShell Snap-Ins did not load.

We've tried removing .Net 4.5 and installing .Net 4.0 (read there is a problem with Exchange 2010 and 4.5).

We can't import a new SSL certificate without the shell.

0

Exact versions of Windows and Exchange 2007 would help here.

Have you tried putting the management tools on to another system, then loading the Shell from there?

Exchange 2007 doesn't use Netframework 4.x at all, it is a 3.5 application.

  • I wasn't sure about the .Net version, but I'm grasping at straws here. I added Server and Exchange versions. Not sure about the Exchange version, so I am updating it now to Service Pack 3 (maybe that will fix it). – Keith Davis Feb 12 '16 at 13:13
  • If you weren't on SP3, then installing that will often fix a lot of issues because it effectively reinstalls Exchange. Don't forget to install the latest rollup for Exchange 2007 as well. – Sembee Feb 12 '16 at 14:25
  • FYI, you are on SP1, as that is 08.01 - when you got SP3 it will change to 08.03. I would also check that you have everything else updated for the server - run Microsoft Update - but of course don't install netframework 4.6! – Sembee Feb 12 '16 at 14:27
  • Yea, I'm doing this for a client and made the assumption that was on the most recent service pack (because I'm a service pack junkie), guess I should have looked at that already (love you Wes, if you are reading this). – Keith Davis Feb 12 '16 at 14:36
  • I got Service Pack 3 installed, however, EMS still does not run and I have 8 updates that will not install. 6 security updates and 2 rollups - Update Rollup 8-v2 for Exchange Server 2007 Service Pack 3 (KB2756497) & Update Rollup 17 for Exchange Server 2007 Service Pack 3 (KB3056710). Both of these rollups fail to install with a message about setup exiting prematurely and I've tried the "fix" (which is supposed to be a UAC workaround, but UAC is disabled on this machine) and the fix does not work either. I'm at a loss. – Keith Davis Feb 21 '16 at 13:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.