1

I have just configured a new server that keeps dying from time to time. The error log indicated the following problem:

[Thu Feb 11 03:21:15.261690 2016] [mpm_prefork:emerg] [pid 1273] (43)Identifier removed: AH00144: couldn't grab the accept mutex
[Thu Feb 11 03:21:15.640431 2016] [core:alert] [pid 1256] AH00050: Child 1258 returned a Fatal error... Apache is exiting!

I tried the solution listed here (basically to add AcceptMutex flock to httpd.conf) , but Apache wouldn't start:

Invalid command 'AcceptMutex', perhaps misspelled or defined by a module not included in the server

So now I don't know what else to do.

4

If you go back and look at the page you linked to, there's a line a little bit further down that says:

With apache 2.4, use Mutex instead of AcceptMutex

2
  • Well...I feel so stupid. – carla Feb 12 '16 at 14:35
  • 1
    @carla Been there, done that... – Jenny D Feb 12 '16 at 14:59
0

Try adding

AcceptMutex posixsem

in your apache conf

2
  • Yes, I tried, and the same "Invalid Command" message appeared when I tried to restart Apache. – carla Feb 12 '16 at 14:23
  • 1
    @carla if you use apache 2.4 Mutex posixsem – ZiTAL Jul 14 '18 at 15:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.