0

I have an Elastix server running in Amazon Web services, but I can't seem to resolve an issue that is causing either one way audio or no inbound calls to ring.

If I set my SIP extensions to "Nat = Yes" they can dial out and audio works fine both ways, however if no phones will ring on inbound calls.

If I set my SIP extensions to "Nat = route - NAT no rport" my phones will ring on inbound calls, but I will have no audio going out to the caller.

I am using Digium D40 and D50 phones, as well as the Bria soft-phone, and unfortunately the Digium phones do not support setting a STUN server.

I have been digging through this guide (http://www.asteriskguru.com/tutorials/sip_nat_oneway_or_no_audio_asterisk.html) on troubleshooting NAT issues, but nothing seems to work.

0

Why do you have NAT in the first place ? The easiest technique is to avoid NAT in the VoIP environment entirely. If your * server is behind NAT - either use VPN or IP ACLs in the sip.conf. If all of your clients are behind NAT - put the server in their LAN and make him multihomed.

One way audio, RTP debugging, ALG fighting - this is a hardcore that is easier to avoid than to handle.

0

It looks like all of my settings were correct I experimented by adjusting the qualify frequency from 60 to 1 and setting NAT to yes, and everything seems to be working as anticipated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.