1

I have exchange 2013 on Azure VM which is also a DC. for using services like autodiscover etc I need to get a valid 3rd Party certificate which I got from STARTSSL, I generated the request and got the certificate downloaded along with private key from STARTSSL. I clicked complete and import the certificate still it says status pending. I also tried the certufil -repairstore my "thumbprint" but it asks for smart card which I cant as my Machine is on AZURE VM, can anyone help please ?

Here is an image about it:

enter image description here

0

That looks to me like the certificate didn't install correctly. Not unusual. You could try downloading the certificate again and see if it will install correctly a second time. Otherwise it will have to be a new request within Exchange so you get a fresh key pair.

You shouldn't have Exchange on a domain controller either...

| improve this answer | |
  • in last 3-4 days i tried this process about 15-20 times, i've been working on it all day and night, I generated CSR through EAC and Powershell, each time they would go pending, when i check the certificate from certmgr it doesnt show any private key associated with it, when i run get-exchangecertificate "thumbprint" it says special rpc error this thumbprint has been found but no private key is missing. certutil is giving above error, i also tried importing the certificate in .pfx format but still doesn't work, it remains in pending status. generated csr request through EAC and PS, but no use – Mashal Khan Feb 13 '16 at 20:14
  • Why not try a free trial certificate from Comodo or one of the others. That will allow you to confirm that the server is working correctly. – Sembee Feb 13 '16 at 21:42
  • I installed local CA and after generating request from my local CA, it accepted and validated the server and i was able to assign services to it. but even trying 10-15 times from startssl it doesn't work, i think the issue is with startssl's certificate, let me try comodo free trial and get back to you after results – Mashal Khan Feb 13 '16 at 21:50
  • ahh leave comodo, is it possible for you to help me by skype call/ screensharing ? – Mashal Khan Feb 13 '16 at 22:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.