For software testing reason, I have registered a domain name, set its A record to point to (local PC on my network). I have installed Comodo Positive SSL for this domain on IIS on Windows 10 on this IP.

I can access mydomain.com under SSL from any external PC browser, within my interal network (I only care for my internal network). The SSL chain is as follows:

SSL Chain

However, when I navigate from an Android's Chrome browser, I am getting "No Certificates Found":

Mo Certificates Found

If I hit cancel, the page loads as expected with green padlock, and the certificate info is as follows:

enter image description here

The other problem that I am having which I think is connected to this problem is that I have a native Android app that is trying to connect to the website, it is working on port 80 but failing connection on SSL (port 443).

I have tried accessing the domain on SSL from an iPhone but connection times out but it is connecting fine on non-secure.

My questions are:

1 - What is the cause of this problem?

2 - How can I solve it? Please note that I don't want to solve it for a particular Android (I probably could solve this by installing the certificate manually), I want to solve it to all potential users.

I tried navigating to another website ( https://lifetanstic.co.ke/ ) that uses the same certificate chain, I wasn't asked to install any certificate, the padlock appears and the certificate details are the same. So, everything worked fine for that site.

Please note that my host name is pointing to an IP in my network, which means it is only accessible from my local network (and the Android is on my local network). So, could that be a factor to this problem?


It appears that you enabled "Require Client Certificate" option in IIS.

Open IIS Manager, select your website, click SSL Settings and switch radiobutton to "Ignore": enter image description here

  • 6 hours trying all sort of solutions, except this one :) Thank you. – Adam Feb 13 '16 at 17:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.