We are trying to setup a wifi environment using WPA2 security using Radius server and AD authentication.

We've set up the radius server using the following guide:

https://networklessons.com/wireless/peap-and-eap-tls-on-server-2008-and-cisco-wlc/

Later when we try to access the wifi ssid it says

Windows was unable to connect.

So I tried checking the logs at C:\Windows\System32 folder and found the error code was 49:

Did not match connection request policy

I changed the connection request policy condition to NAS IPv4 Address : (IP address of my AP which is trying to authenticate) and now when I tried to connect I do not see any logs being created (neither in the log file nor in the event logs).

Event viewer for NPS shows event id 4400, there is no other event generated.

I've tried to monitor the the radius server using NETMON tool and I could see packets with EAP protocol being sent to the radius server but it doesn't send anything back.

I also used the tool NTRADPING to test, but it says Access-reject and on monitoring the network, I could se packets with protocol RADIUS being sent and received.

I tried reinstalling the roles ADCS and NPS again but it didn't help.

I've tried almost all possible combinations of Network and Connection policies but couldn't get it to work.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.