1

We have a Windows Server 2012 R2 machine that we're using as a Remote Desktop Services server for our employees. It has the "RemoteApp" feature set up so that everybody can run our pre-configured software without needing it installed on their local machines.

I have the newest version of Java Runtime installed (Java 8 Update 73), and the Oracle website itself is able to verify the installation. Additionally, our desktop programs that require Java runtime work as well.

But when I open any website that prompts to allow or block the plugin, the prompt just keeps re-appearing.

"This webpage wants to run the following add-on: 'Java SE Runtime Environment 8 Update 73' from 'Oracle America, Inc.'."

If I click Allow, the page refreshes and the prompt comes right back. Even if I select "Allow for all websites", it keeps coming back.

I've tried doing a complete reset of IE to factory defaults, then re-enabling the plugin and the prompt will still continue to come up.

I thought it might be site-specific (we're trying to set it up to print UPS labels using our thermal printer), so I tried this site: http://www.pinlady.net/PluginDetect/Java/

Same behavior. The prompt just keeps popping up and nothing happens.

I compared the Internet Options settings with another 2012 R2 machine, one that works fine with Java, and they are identical.

I've also tried completely uninstalling Java and reinstalling it. No dice.

What else can I do to fix this problem?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.