0

I have the following configuration of isc-dhcpd-4.3.1:

ignore client-updates;
ddns-update-style interim;
subnet 192.168.128.0 netmask 255.255.255.0 {

    use-host-decl-names on;
    update-static-leases on;

    key "rndc-key" {
            algorithm hmac-md5;
            secret "redacted";
    };
    zone example.com. {
            primary 127.0.0.1;
            key rndc-key;
    }
    zone 128.168.192.in-addr.arpa. {
            primary 127.0.0.1;
            key rndc-key;
    }

    authoritative;
    range 192.168.128.32 192.168.128.63;

    next-server 192.168.128.1;

    option domain-name "example.com";
    option domain-name-servers 192.168.128.1;

    group {
            host test {
                    hardware ethernet 00:00:00:00:00:00;
            }
    }}

What is happening is that despite the ignore client-updates, the ddns entries created are defaulting to the server's hostname at the time of the dhcp query, ie: localhost.example.com. The server, after it's initial dhcp query correctly sets its hostname to test.example.com and a service networking restart will then have the correct DDNS entries created.

I am at a complete loss as to why dhcpd is listening to the client sending a hostname of localhost despite the setting telling it not to.

Some assistance with this would be great.

1

I had the same problem and came up with the solution to add ddns-hostname to the host config. use-host-decl-names neither ignore client-updates change any behavior of the dhcpd.

The following function worked finally, even tho clients still tried to update the dns with their hostname:

host client.foo.bar {
        hardware ethernet 00:00:00:00:00:AA;
        fixed-address 192.168.42.2;
        ddns-hostname "foo";
        }

If you find a better solution please let me know!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.