0

I have a Netapp with some NFS exports for VMware storage. I want to mount the snapshots on a Windows 2012 R2 server in order to copy all of the virtual machine files to tape. I can mount the share just fine, but I can only copy some of the files. They have various permissions; some are 600, some are 644, and some are 755. It's the 600 ones that I cannot copy. I get an error in Windows when trying to copy those. The other files copy just fine. I've tried various options in the mount command, but to no avail. I'm pretty sure it's not an option to change the file permissions. Is there any other solution?

1

Instead of using Windows to mount VMWare VM files, I'd just use the Netapp to directly write to tape.

  • That was going to be my question- why is the windows box writing them to tape for the netapp. – Jim B Feb 17 '16 at 4:35
  • The tape drive is physically connected to the Windows box because we're using LTFS. That way we'll have the raw files on tape. We're also using the same Windows box to mount iSCSI LUN's to back up the files in those too. (I already have that part worked out). We're also backing up files that are on CIFS shares. Also the Netapp didn't have any open PCI slots for the SAS card that the tape drive connects to. We did consider all of that, and connecting the tape drive to a Windows box seemed like the best option. – Charles Burge Feb 17 '16 at 17:07
  • I'm not an expert on VMWare, but I don't think they went out of their way to allow this kind of thing. Can you install backup software on a VM and get it access to that tape drive? I found this: kb.vmware.com/selfservice/microsites/… – Basil Feb 18 '16 at 2:20
0

I found a work-around. Since the LTFS software presents the tape drive as a logical disk drive in Windows, I shared that drive. Then I created a Linux VM, and mounted the share on it. In the Linux VM I can mount the NFS share and copy everything without any errors. So at that point it's just a matter of using rsync to copy from one mount point to the other.

Incidentally, that confirms my suspicion that there's something funky about the way Windows mounts NFS shares.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.