1

I trying to set up subdomain (e.g mail.mydomain.com) for use with a virtual SMTP server running on windows server 2012 SP2.

I’ve tried to telnet with the command ‘telnet mail.mydomain.com 25’ but it doesn’t connect.

In the properties window of the SMTP server on the Access tab both the ‘Connection’ and ‘Replay restrictions’ have my domain (e.g mail.mydomain.com) added.

enter image description here

  • My nameservers have the correct record ‘A’ pointing to my domain
  • I have a firewall rule to open port 25
  • I have successfully telnet tested it using the ip address of the server on my local network and the server name. But the new mail subdomain I have set up stubbornly won't connect
  • At the moment I'm just using anonymous authentication
  • Setup MX record on the NameServer, not sure if necessary
  • TLS is not enabled

enter image description here

Under the delivery tab's Advanced dialog, We have the following settings:

  • Masquerade domain: nothing
  • Fully-qualified domain name: mail.mydomain.com
  • Smart host: none
  • You've telnet successfully on your local network shows that the port is listening properly. I assumed those are in the same domain as the virtual SMTP. Even though this is a child domain and the trust relationship is established by default, can you doublecheck to make sure it's configured in your Domain & Trust on both parent/child domain? – Lex Feb 19 '16 at 18:44
  • Thanks for the reply Lex. When I mentioned domain this is just my website domain name (eg example.com) and I don’t have Active Directory set up at all, this server is purely a standalone webserver with IIS running on it so I don’t think this needs any ‘Domain & Trust’ settings applied just that’s AD stuff right. Just to summarize so from another pc on the network: telnet 192.168.1.101 25 - Works telnet Server-Name 25 - Works telnet mail.myWebsiteAddress.com 25 - Doesn’t work – Hevski Feb 19 '16 at 19:33
  • Summary: Internal-IP:25 works, External-IP:25 doesn't work? – Dom Feb 20 '16 at 3:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.