0

None of the new CNAME and TXT records I add (through VestaCP) are working.

My DNS server has been working fine. Got about 30 domains on it, used to be able to create these records and a few hours later they would be working.

But now, no joy. Add records, a few days later, still nothing.

What I can see it that those records by VestaCP are writen to an example.org.db file which is then included in /etc/bind/named.conf:

zone "example.org" {type master; file "/path/to/example.org.db";};

How do I troubleshoot this? I've tried, but so far haven't figured it out.

Should add that I'm checking that these records can be found through mxtoolbox.com

EDIT:

The domain name is: cedarvale.org

Example Records:

_amazonses.cedarvale.org        14400   IN      TXT             tP8Ni9mnCdomIpnVvx0eYyD//GxCTVXO3XslbmgrcQ0=
unn3jseoejfwzgh2p7oqfh76nlftl42f._domainkey.cedarvale.org       14400   IN      CNAME           unn3jseoejfwzgh2p7oqfh76nlftl42f.dkim.amazonses.com.
  • I assume you made an error formatting the record and those should be two separate lines? – HBruijn Feb 23 '16 at 7:03
2

In a DNS zone file shorthand a resource record without a trailing . is appended with the $ORIGIN (typically the name of the zone).

The host _amazonses.cedarvale.org you have added then effectively becomes _amazonses.cedarvale.org.cedarvale.org.

That may not be the only problem though, as I can't resolve that record either and I noticed that ns2.emanwebdesign.com. is not responding at all.

| improve this answer | |
2

Your nameserver setup is broken. I ran your zone through DNScheck; it shows that one of your nameservers isn't responding at all, and the other one has a difference of opinion with the root servers as to which servers should be authoritative for your domain. Once you've fixed this, you can have a look at specific records.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.