1

Let me say I'm very new to Server administration.

We currently have a Windows Server 2012 in workgroup configuration. We have RDS in Per Device license mode. Now one of the user need multiple access to the server. We purchased and installed per user CALs. Since RDS is installed in per device mode, user CALs appear as available, but are not getting issued.

RDS License Manager

  1. Is there a way to change the RDS license mode from device to user? I don't have session host available, and can't find a way to access "Remote Desktop Session Host Configuration". The overview branch on shows nothing to change license mode:

RDS Panel on Server Manager

  1. Once the license mode changes from Per Device to Per User, does it require server restart?

  2. what are some considerations before undertaking this?

Thanks.

1

You may use Local Group Policy (gpedit.msc) to specify the Licensing Mode:

enter image description here

  • Thanks Greg. But, I don't have "Remote Desktop Services" branch there. Can you provide its complete path here? – SJaka Feb 23 '16 at 17:17
  • Found it under: Computer Configuration/Administrative Templates/Windows Components/Remote Desktop Services/Remote Desktop Session Host/Licensing – SJaka Feb 23 '16 at 17:24
0

You can change the licensing mode. When working with server 2012 (R2) you need to configure the session collection.

A server restart is not required. Changing the licensing mode shouldn't even trigger existing sessions to be disconnected (only new sessions should be affected) - depending on the options that are modified on a session collection (like adding/removing gateway) existing sessions are dropped (will be reconnected).

Ensure that your license server provides the licenses you need (device or user) and that you still are using license according to the terms.

There's an existing question about setting the licensing mode available here.

  • Thanks for your response Daniel. We are using Windows Server 2012, not R2. Also, there is no session collection available on server manager. – SJaka Feb 23 '16 at 16:23
  • i edited the answer and added a link to another SO question. there you may find more information about this topic. – Daniel Nachtrub Feb 23 '16 at 16:38
  • I read that link earlier. As the image I attached shows, on the overview branch, I don't have anything at all, except a message. I believe these are applicable on domain controllers, not workgroup settings. – SJaka Feb 23 '16 at 16:47
  • then i refer you to the solution from Gred - use local gpo to set the licensing mode – Daniel Nachtrub Feb 23 '16 at 17:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.