Trying to get a wildcard cert working on Exchange 2013 for IMAP purposes. Unable to add in ECP (receives error about it not having a FQDN since its a wildcard)

So then I try to run:

Set-ImapSettings -X509CertificateName sub.domain.com

However, I receive an error:

WARNING: The command completed successfully but no settings of 'SERVERNAME\1' have been modified.

It never enables the IMAP setting for this cert. I have verified with Get-RoleGroupMember that I am logged in as someone with Server Management capabilities. Running Get-ExchangeCertificates | fl shows that IMAP service is never tying to this certificate.

Scoured the internet and my mind and can't find why my Set-ImapSettings isn't working correctly.

Any suggestions? Not getting anything in event viewer that points to anything, I've restarted IMAP services (backend and imap4), tried to force enable IMAP service in powershell (Enable-ExchangeCertificate -Thumbnail xxx -Services imap), nothing has worked.


It doesn't show but normally IMAP should still be using the certificate after completing the commands. Did you verify this? Do you get a certificate error when trying to connect to IMAP with a mailbox in Outlook? If it didn't work, then you should get a certificate error (and if you then click "Show Certificate" you should see the self-signed certificate from your Exchange server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.