1

Edit:

It would appear that the problem has somehow magically disappeared after leaving everything alone for almost 24 hours. After just sitting down to look into it further, I notice that my website loads.

I would delete this question if it were not for the existing response.


I have a virtual machine running on HyperV that was working perfectly fine not a couple days ago, but suddenly refuses to let me connect to it from the host OS, but I can connect just fine from other VMs and from other physical machines on the network.

It will respond just fine to pings, but any attempt to SSH into it or access its httpd server results in "Connection Refused".

iptables and selinux are both disabled on the machine.

Here is the output of ip addr on the VM in question, as well as the ip information for the host OS:

Windows

Ethernet adapter vEthernet (Public):

   Connection-specific DNS Suffix  . : <hidden>
   Description . . . . . . . . . . . : Hyper-V Virtual Ethernet Adapter
   Physical Address. . . . . . . . . : 40-16-7E-A8-B7-39
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::35ea:cf60:b4e3:c15%18(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.2.150(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Sunday, February 28, 2016 8:14:24 PM
   Lease Expires . . . . . . . . . . : Monday, March 07, 2016 8:14:22 PM
   Default Gateway . . . . . . . . . : 192.168.2.1
   DHCP Server . . . . . . . . . . . : 192.168.2.6
   DHCPv6 IAID . . . . . . . . . . . : 121640574
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1D-3B-94-11-40-16-7E-A8-B7-39
   DNS Servers . . . . . . . . . . . : 192.168.2.6
                                       192.168.2.10
   NetBIOS over Tcpip. . . . . . . . : Enabled

CentOS 7

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 00:15:5d:02:96:0f brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.16/24 brd 192.168.2.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::215:5dff:fe02:960f/64 scope link
       valid_lft forever preferred_lft forever

Windows Server

For completeness, here is my domain server IP details which has no problem accessing the server in question.

Ethernet adapter vEthernet (Intel(R) 82566DC Gigabit Network Connection - Virtual Switch):

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Hyper-V Virtual Ethernet Adapter #2
   Physical Address. . . . . . . . . : 00-16-76-CA-1A-93
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::8d04:b94b:beb3:d3bf%17(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.2.6(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.2.1
   DHCPv6 IAID . . . . . . . . . . . : 301995638
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1C-E9-73-B5-00-16-76-CA-1A-93

   DNS Servers . . . . . . . . . . . : ::1
                                       127.0.0.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

How might I go about troubleshooting this? It makes no sense to me whatsoever.

3

Are you using iptables instead of firewalld? Starting from CentOS7 it's using firewalld by default.

You can check your firewalld entry of CentOS by issueing;

#firewall-cmd --list-all

And some more background on: http://www.tecmint.com/configure-firewalld-in-centos-7/

  • I had read something about firewalld yesterday while briefly debugging, and found that it appeared to be off as well. But in any event, it seems like the problem magically disappeared after having done nothing with the PC for almost 24 hours. – agent154 Feb 29 '16 at 23:33
  • firewalld is still a front-end for iptables - iptables -v -L would still be useful for figuring out the current rules (and it might show rules added from other sources, like intrusion detection systems), but firewall-cmd should be used for changes... – Gert van den Berg Mar 18 '16 at 10:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.