I have a Debian server sharing files via Samba. I can access the files via Windows with no problems whatsoever, but when I try to mount the share on a Fedora client using the same credentials I am unable to write to any files. I have proper read access, but no write permissions.

Here are the settings for the share from my smb.conf:

path = /opt/lampp
writable = yes
browsable = yes

I have to assume that it is an issue on the Fedora side of things because accessing the share from Windows works fine. I have also tried mounting via SSHFS with no luck; it also will allow me to read files but not write. However, in Windows, using a program called WebDrive I am able to access the files (essentially via SSHFS) with no issues whatsoever.

I have tried setting up NFS but not much luck there either; I'd rather just stick with Samba if possible.

Any suggestions?

  • How are you accessing things from fedora? There are several different CIFS clients. – Zoredache Oct 19 '09 at 19:11
  • Generally just by adding a line to /etc/fstab. I don't remember the exact syntax off the top of my head. Are there other ways to do this? I've given sshfs a shot too but it has the same read/write permissions issues. – norova Oct 22 '09 at 3:38

I've already answered very similiar question here. Take a look: How to make new copied file always 777 permission

Problem is definetely in permissions. Windows takes them very vaguely, but Linux compares UID of user which access the file, and UID of the owner of file. And it's not sufficant to log in as user of the same name, the UID has to be right. This can be accomplished by seting uid and gid option in smbmount.

For example:

smbmount //server/share /mount_point -o uid=1023,gid=1000




My guess would be permissions on the directory itself. Nine times out of ten I forget to change these permissions.

  • I assume its not directory permissions because I'm using the same credentials for every method I try. – norova Oct 22 '09 at 3:35

I also have some partition being shared with samba. The samba server is on a Debina machine running Unstable. I have noticed that I need to have the shared directories owned by the smbuser group.

I access the shared directories with the command shown below.

$> smbmount  //SambaServer/Share1 ~/mnt/S1 -o user=mysername

where SambaServer is the name of the host runnign the Samba server, Share1 is the name of the partition to be shared on it, ~/mnt/S1 is the directory where I want to mount the shared folder and mysername is my username on the Samba server machine.

On the Samba server machine, I have the following stanza in /etc/samba/smb.conf:

        comment = Shared folder 1
        browsable = yes
        guest ok = no
        path = /media/Share1
        writable = yes
        force create mode = 0770
        force directory mode = 0775

And the permissions of /media/Share1 are: drwxrwsr-x owned by root:smbuser

Good luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.