I have a datastore set up in ESXi where I put all my ISOs. Somehow, something broke (I don't know what) and now I can't upload files to that (or any other) datastore. For large, ISO-sized files, the "Uploading..." dialog pops up, hangs for a while, and then the "I/O Error Occurred" displays. For smaller files (10 meg neighborhood), the "Uploading..." dialog comes up, a progress bar starts going, and it estimates a time remaining. Then it hangs at 1 second remaining for a while, and the same "I/O Error Occurred" comes up.

Has anyone seen a problem like this?


There have been known issues with ESXi's datastore browser (and other file transfer methods) throwing this error sometimes intermittently, sometimes only for large files - I haven't ever seen a definitive fix for all cases but many seem to be related to network hardware. I've never seen the issue but I've only ever installed ESXi on fully certified hardware. What is the hardware config that you are using, which NIC's in particular and were any of the changes you might have made possibly related to the NIC settings or drivers (ie did you run an update)?

| improve this answer | |
  • It's running on a Dell Poweredge r900 with four Broadcom 5708 NICs. I believe the Poweredge r900 is ESX certified in that configuration. I really don't know what changes were made -- I'm trying to clean up after someone else's mess. – Chris Oct 19 '09 at 21:03
  • Yeah the R900 is Grade A certified. One thing I have found with those Broadcoms is that they sometimes don't like being set to Auto-Negotiate - if you can fix them at 1000Mbps\Full Duplex things might improve but I suspect that if that is the cause you'd be seeing very poor network performance across the board. – Helvick Oct 19 '09 at 21:26
  • Surprisingly, the problem was just the opposite. The management nic was locked in 100 Full. It complained when I tried to switch it to gig full, but when I switched it to Auto, it started working. When I told my boss, he all-of-the-sudden remembered that what changed was that we moved that box from a 100 Meg switch to a Gig switch. – Chris Oct 19 '09 at 21:41

changing to auto-neg worked a treat for me

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.