1

Notice: This is a repost from StackOverflow.

I am trying to push a Windows Core Docker Image into my Docker Hub account. The error message (1) I am getting is:

$ docker push <MY_DOCKER_HUB_USERNAME>/<MY_IMAGE>
The push refers to a repository [docker.io/MY_DOCKER_HUB_USERNAME/MY_IMAGE] (len: 2)
46e2fd82ef4a: Preparing
Error parsing HTTP response: invalid character '<' looking for
beginning of value: "<html><body><h1>403 Forbidden</h1>\nRequest
forbidden by administrative rules.\n</body></html>\n\n"

Before pushing I am getting properly authenticated from my Mac OS X box by means of login usage:

$ docker login --username=<MY_USERNAME> --email=<MY_EMAIL@MY_SERVER.COM>
WARNING: login credentials saved in /Users/<MY_USERNAME>/.docker/config.json
Login Succeeded

Once I am authenticated, I see no point in getting a "403 Forbidden" error from Docker Hub. Also, it is not clear what these "administrative rules" are, but perhaps they are preventing me from getting my image pushed into Docker Hub registry. Please note that my repository is flagged as "public" as well my default policy ("Default Repository Visibility" from "Settings" in Docker Hub Dashboard).

I tried to do the same within my Windows Server Core box and was not able to get authenticated using the same credentials:

C:\>docker login --username=<MY_USERNAME> --email=<MY_EMAIL@MY_SERVER.COM>
Password:
Error response from daemon: Unexpected status code [403] :
<html><body <h1>403 Forbidden</h1>
Request forbidden by administrative rules.
</body></html>

Docker Client Version from Windows Core box:

C:\>docker --version
Docker version 1.10.0-dev, build 59a341e

Docker Client from Mac OS X box:

$ docker --version
Docker version 1.9.1, build a34a1d5

Windows Server Core version:

PS C:\> [System.Environment]::OSVersion.Version

Major  Minor  Build  Revision
-----  -----  -----  --------
10     0      10586  0

P.S.: No matter if I try to push from inside of my Mac OS X box (using my Windows Core box exposed API) or straight from inside of my Windows Core box, they will always lead to the same error message (1). It points me that the whole process depends on the authentication by the Windows Server Core box and since it is not properly working the results will always be the same.

0

At this time, that is expected behavior. Docker is still in the early stages of Windows development. This documentation specifically states that commands related to DockerHub are not supported yet. According to jhowardmsft in #docker-dev (Freenode): "With (Win Server 2016) Technical Preview 4, it should be able to push to a Docker Trusted Registry".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.