1

One system has CIFS autofs home directories. I can upload files without issue but it seems to be failing on the final rename:

enter image description here

But I can see the file uploaded, just with the .filepart extension:

enter image description here

The final file is intact, the only thing that seems to be failing is the rename operation. I don't know why that would be the case. I've already tried to do directio on the directory and this isn't reproducible on NFS automounts on the same server. I have seen this and Symantec AV is running but this isn't happening on NFS and even with AV disabled I still get the error.

I'm kind of at a loss as to what to check

EDIT:

Added wrinkle, the error does not appear if the file is small (such as 9KB). It's only large files that have this issue.

  • "the error does not appear if the file is small (such as 9KB)" - Because WinSCP uses transfer to a temporary file name for files over 100 KB only (by default). – Martin Prikryl Mar 3 '16 at 16:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.