1

I have a Cisco Catalyst 3850. I added a network module with 4 gbic for fiber connection. The module is not showing any lights on either side of the connection. After the searching the depths of the internet I found out that when adding a network module like I did I have to enable the media-type of sfp for those interfaces. This is what I have tried.

enable

conf t

int tengigabitethernet 1/1/1

media-type sfp

it's not wanting to take this command. is this the right way to enable media-type sfp?

Show inventory command:

flcoffice_48m_01#show inv
NAME: "c3xxx Stack", DESCR: "c3xxx Stack"
PID: WS-C3850-48T      , VID: V04  , SN: FCW1905C178

NAME: "Switch 1", DESCR: "WS-C3850-48T"
PID: WS-C3850-48T      , VID: V04  , SN: FCW1905C178

NAME: "Switch 1 - Power Supply A", DESCR: "Switch 1 - Power Supply A"
PID: PWR-C1-350WAC     , VID: V01  , SN: LIT19221FY 

NAME: "Switch 1 FRU Uplink Module 0", DESCR: "4x10G Uplink Module"
PID: C3850-NM-4-10G    , VID: V01  , SN: FOC19238XKL

NAME: "TenGigabitEthernet1/1/1", DESCR: "1000BaseSX SFP"
PID: GLC-SX-MMD         , VID: V01  , SN: FNS19270TD6    

NAME: "TenGigabitEthernet1/1/2", DESCR: "1000BaseSX SFP"
PID: GLC-SX-MMD         , VID: V01  , SN: FNS19270TQ0    

NAME: "TenGigabitEthernet1/1/3", DESCR: "1000BaseSX SFP"
PID: GLC-SX-MMD         , VID: V01  , SN: FNS1920059J   

here is the errdisable recovery command:

flcoffice_48m_01#show errdisable recovery 
ErrDisable Reason            Timer Status
-----------------            --------------
arp-inspection               Disabled
bpduguard                    Disabled
channel-misconfig (STP)      Disabled
dhcp-rate-limit              Disabled
dtp-flap                     Disabled
gbic-invalid                 Disabled
inline-power                 Disabled
l2ptguard                    Disabled
link-flap                    Disabled
mac-limit                    Disabled
loopback                     Disabled
pagp-flap                    Disabled
port-mode-failure            Disabled
pppoe-ia-rate-limit          Disabled
psecure-violation            Disabled
security-violation           Disabled
sfp-config-mismatch          Disabled
storm-control                Disabled
udld                         Disabled
vmps                         Disabled
psp                          Disabled
Recovery command: "clear     Disabled
10
  • What error message do you get when you issue the media-type sfp command? Can you post the output of show inventory? (Please add the show inventory output by editing your question) – Todd Wilcox Mar 3 '16 at 17:37
  • 3
    You don't need that command unless there is a corresponding copper port that shares the port. It just clarifies whether you use the built-in copper port or the SFP port. The module for the 3850 only has SFP ports, so you don't use this command. – Ron Maupin Mar 3 '16 at 17:46
  • I agree with Ron. We have several little brothers (the 3650 line) to your switches, modules, and SFPs here that I've integrated and configured from scratch (I just did one yesterday) and we haven't needed to use the media-type command. When a connection doesn't light up for us, we look at the fiber, make sure it's the right kind, plugged in correctly, etc. – Todd Wilcox Mar 3 '16 at 18:00
  • 1
    Errdisabled means there's a reason why the system has disabled the port. This question should probably be edited to one about troubleshooting errdisabled ports. Run show errdisable recovery to see the reason why the port was disabled. Then you can troubleshoot that reason. See here: cisco.com/c/en/us/support/docs/lan-switching/… – Todd Wilcox Mar 3 '16 at 18:28
  • 1
    You have something configured incorrectly for how you want to use the ports if you are getting errdisable on the port. You should edit the question to include the switch configuration. Don't type it in, but copy and paste into the question. These sorts of questions should be asked on Network Engineering. – Ron Maupin Mar 3 '16 at 18:56
0

Check if your interfaces are in err-disabled. If so, it's due to a known Cisco bug where it states gbic-invalid (even though it is valid) , you can manually shut no shut the interface with the SFP or add errdisable recovery cause gbic-invalid to your config. Possibly the bug will be fixed in future IOS releases.

Tidy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.