0

I'm running a virtual image (which happens to be our server for a number of programs) on a machine running ESXi 5.5.0. Although the host computer has a SSD of about 200GB, the virtual image was initially given a 40GB virtual disk. Unfortunately, it is a "thick provision lazy zeroed" type disk, and cannot be expanded using ESXi's GUI system.

I recently tried using vmkfstools to expand the VMDK (vmkfstools -X 60GB myimage.vmdk). This command completed successfully but the joy was short lived when I tried to boot up:

The capacity of the parent virtual disk and the capacity of the child disk are different

I initially tried shrinking the disk I changed back to 40GB, but this didn't work. A little research has said I need to open the descriptor using vi but I'm unsure if this would work (and where the descriptor is).

Would anyone have any suggestions on how to resolve this?

0

Why dont you try VHDResizer? See if it works for you.

But the issue is it works for VHDs only. You can convert your VMDK to VHD and try.

Another tip: Make a copy/ backup of the Disk file before you try such operations on them.

Even if I use VMWare I prefer to use VHDs as they are cross compatible across various VM platforms.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.