1

When I searched for this error, it seems to be more common in CentOS but I'm using Ubuntu 15.10.

My issue is that I've followed this installation on ffmpeg-php's site and I've ran into an error when doing this command.

./configure && make

The following error I recieve is

checking for grep that handles long lines and -e... /bin/grep checking for egrep... /bin/grep -E checking for a sed that does not truncate output... /bin/sed checking for cc... cc checking whether the C compiler works... yes checking for C compiler default output file name... a.out checking for suffix of executables... checking whether we are cross compiling... no checking for suffix of object files... o checking whether we are using the GNU C compiler... yes checking whether cc accepts -g... yes checking for cc option to accept ISO C89... none needed checking how to run the C preprocessor... cc -E checking for icc... no checking for suncc... no checking whether cc understands -c and -o together... yes checking for system library directory... lib checking if compiler supports -R... no checking if compiler supports -Wl,-rpath,... yes checking build system type... x86_64-unknown-linux-gnu checking host system type... x86_64-unknown-linux-gnu checking target system type... x86_64-unknown-linux-gnu checking for PHP prefix... /usr checking for PHP includes... -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib checking for PHP extension directory... /usr/lib/php5/20131226 checking for PHP installed headers prefix... /usr/include/php5 checking if debug is enabled... no checking if zts is enabled... no checking for re2c... no configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers. checking for gawk... no checking for nawk... nawk checking if nawk is broken... no checking for ffmpeg support... yes, shared checking whether to force gd support in ffmpeg-php... no checking for ffmpeg headers... configure: error: ffmpeg headers not found. Make sure ffmpeg is compiled as shared libraries using the --enable-shared option

How do I fix this? Some people said to just do sudo apt-get install ffmpeg-dev`` orffmpeg-devel` but neither have worked and it's getting frusterating that there's no solution for this right now. It's like I'm the only one having this issue.

And yes my FFMPEG is installed, if I type in ffmpeg -cmd then I receive data from ffmpeg. And I am able to encode a video so it IS installed.

  • ffmpeg-php is long dead and unmaintained since 2007; or at least upstream is. I don't see how it is possible to work with any supported version of ffmpeg. Are you sure you even need a PHP wrapper? See FFmpeg Wiki: PHP. – llogan Mar 26 '16 at 18:32
1

In Ubuntu, FFmpeg headers are distributed among several packages, which are built from the ffmpeg source package. I guess you should install all of them (list here):

$ sudo apt-get install libavcodec-dev libavcodec-ffmpeg-dev libavdevice-dev libavdevice-ffmpeg-dev \
libavfilter-dev libavfilter-ffmpeg-dev libavformat-dev libavformat-ffmpeg-dev libavresample-dev \
libavresample-ffmpeg-dev libavutil-dev libavutil-ffmpeg-dev libpostproc-dev libpostproc-ffmpeg-dev \
libswresample-dev libswresample-ffmpeg-dev libswscale-dev libswscale-ffmpeg-dev
  • That did not fix my issue. I still get the same issue unfortunately. – Cameron Swyft Mar 7 '16 at 4:03
  • Try installing libavfilter-dev also. If it doesn't work, try installing every -dev package that is built from the ffmpeg source package (list) . – Anderson M. Gomes Mar 7 '16 at 4:14
  • Issue still remains :( I don't understand how codec files would relate to how I cannot install ffmpeg-php. Should be something directly with Ubuntu & FFMPEG don't you think? – Cameron Swyft Mar 7 '16 at 4:19
  • @CameronSwyft, I edited my answer again. Could you try it? – Anderson M. Gomes Mar 7 '16 at 4:49
  • Still same issue :((( – Cameron Swyft Mar 7 '16 at 4:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.