0

I am trying to set up a shibboleth configuration but have now hit an error I do not know how to deal with:

When accessing a site, which I configured to be protected by shibboleth, I receive a 500 error, with apache's error log stating:

[authn_core:error] AH01796: AuthType shibboleth configured without corresponding module

However I already have shib2 enabled and correctly loaded:

# a2enmod shib2
Module shib2 already enabled
# cat /etc/apache2/mods-enabled/shib2.load
LoadModule mod_shib /usr/lib/apache2/modules/mod_shib2.so
# ls /usr/lib/apache2/modules/mod_shib2.so -l
-rw-r--r-- 1 root root 150344 Mär 28  2015 /usr/lib/apache2/modules/mod_shib2.so

I am very puzzled by this error. Especially since it used to work earlier.


Edit: apache's virtualhost config

<VirtualHost [ip]:8081>
    DocumentRoot            /var/www/sp

    <Location /shibboleth-sp>
        Allow from all
    </Location>
    Alias /shibboleth-sp/main.css /usr/share/shibboleth/main.css
    Alias /shibboleth-sp/logo.jpg /usr/share/shibboleth/logo.jpg

    <Location /secure>
        AuthType                shibboleth
        ShibRequireSession      On
        require                 valid-user
    </Location>

    Redirect seeother /shibboleth http://[ip]/Shibboleth.sso/Metadata
</VirtualHost>
0

Turns out that IF you use the RequestMapper directive in shibboleth2.xml, even for other sites, then you also HAVE to create a Host directive for Apache, even though that's usually not required.

In my case I currently try to configure nginx to talk to shibboleth. Using this nginx module, I had to configure a Host directive, which then also worked. Then, for testing purposes, I wanted to enable Apache's mod_shib again and even though it used to work, it didn't anymore.

Specifically adding the Apache Host to shibboleth2.xml solved this problem.

It is quite interesting to note that this problem resulted in the above error message...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.