1

I have 5 Centos machines and 2 of them have virtual IP enable on it. This is causing problem for some of the application specifically MapR.

Here i need to disable virtual IP address.

I have a temprory solution which is below command:

sudo ifconfig virbr0 192.168.122.1  netmask 255.255.255.0 down

It works for a session but when i reboot the system it automatically get up i cannot find any ifcfg-virbr0 entry in network-script how can i disable it on startup.

  • do you have libvirt on the system? – ALex_hha Mar 10 '16 at 14:46
  • @ALex_hha No we don't have it. – Vikas Hardia Mar 11 '16 at 5:15
0

I don't think you need to disable virbr0.

On MapR, you may want to investigate MAPR_SUBNETS. From the documentation for MapR 5.2:

By default, MapR automatically uses all available network interface cards (NICs) on each node in a network. However, in some scenarios you might want MapR to use a restricted subnet of NICs. For example, if you use multiple NICs of mixed speeds (such as 1GbE and 10GbE) on each node, you might want to separate them into two subnets. That way, you can use the faster NICs for MapR and the slower NICs for other functions.

So in your case, MAPR_SUBNETS should be set to the subnet on the interfaces that you want MapR to use for its traffic (RPCs between nodes). MapR will then not consider interfaces not in the subnets in MAPR_SUBNETS for cluster communication.

HTH

--vince

-1

The virbr0 is a 'dummy' device that accompanies actual br0 bridge. So maybe what you want to do is to completely disable br0. Search the network scripts for DEVICE=br0. If not found, search the initialization scripts for br0 maybe some manual cruft is to be discovered there.

The relevant documentation is at https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/5/html/Virtualization/sect-Virtualization-Network_Configuration-Bridged_networking_with_libvirt.html

  • i created ifcfg-br0 script and set onboot=no but it dint worked. – Vikas Hardia Mar 10 '16 at 13:31
  • virbr0 is not a dummy device, it is itself an actual bridge. – Michael Hampton Mar 10 '16 at 14:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.