-1

This question already has an answer here:

I have a send-only mail server setup on an Ubuntu VPS. The mail server is only used to send out registration e-mails from a web application. I have the following configured:

  • DomainKeys Identified Mail (DKIM)
  • Sender Policy Framework (SPF)
  • DMARC
  • Resolvable hostname
  • rDNS

I've also tested my mail server with mail-tester.com and gotten a 10/10 rating (See report). The following is from my mail.log:

Mar 13 14:44:16 server postfix/pickup[5922]: 8147712289A: uid=33 from=<noreply@my-domain.me>  
Mar 13 14:44:16 server postfix/cleanup[6311]: 8147712289A: message-id=<43fd440eaa77a6bb9f4b28e608f4c335@bugs.my-domain.me>  
Mar 13 14:44:16 server opendkim[943]: 8147712289A: DKIM-Signature field added (s=mail, d=connect-ats.com) Mar 13 14:44:16 server postfix/qmgr[1102]: 8147712289A: from=<noreply@my-domain.me>, size=982, nrcpt=1 (queue active)  
Mar 13 14:44:16 server postfix/smtp[6313]: 8147712289A: to=<ralph@outlook.com>, relay=mx2.hotmail.com[65.54.188.72]:25, delay=0.38, delays=0.07/0.01/0.23/0.07, dsn=5.0.0, status=bounced (host mx2.hotmail.com[65.54.188.72] said: 550 SC-001 (BAY004-MC1F33) Unfortunately, messages from 159.203.23.75 weren't sent. Please contact your Internet service provider since part of their network is on our block list. You can also refer your provider to http://mail.live.com/mail/troubleshooting.aspx#errors. (in reply to MAIL FROM command))  
Mar 13 14:44:16 server postfix/smtp[6313]: 8147712289A: lost connection with mx2.hotmail.com[65.54.188.72] while sending RCPT TO  
Mar 13 14:44:16 server postfix/cleanup[6311]: DD9C612350D: message-id=<20160313134416.DD9C612350D@server.my-domain.me>  
Mar 13 14:44:16 server postfix/qmgr[1102]: DD9C612350D: from=<>, size=3860, nrcpt=1 (queue active)  
Mar 13 14:44:16 server postfix/bounce[6314]: 8147712289A: sender non-delivery notification: DD9C612350D Mar 13 14:44:16 server postfix/qmgr[1102]: 8147712289A: removed 
Mar 13 14:44:17 server postfix/smtp[6313]: DD9C612350D: to=<noreply@connect-ats.com>, relay=none, delay=0.21, delays=0/0/0.21/0, dsn=5.4.6, status=bounced (mail for my-domain.me loops back to myself) Mar 13 14:44:17 server postfix/qmgr[1102]: DD9C612350D: removed

I have gone over my configuration multiple times and the only thing I've found that may be an issue is the message ID, included in the log above. The web app is running at bugs.my-domain.me while I'm sending e-mails as noreply@my-domain.me and I don't have SPF settings for that domain,

marked as duplicate by Jenny D, Ward, MadHatter, Jim B, mdpc Mar 16 '16 at 0:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

To begin with, your subject mentions Google, but your logs reference hotmail, I'll assume you have problems with both.

You are sending as noreply@my-domain.me, but apparently that e-mail does not exist since your own server cannot find it. You should create it. You should also set up SPF setting for your domain: in the beginning of your post you say you have DKIM and SPF and DMARC configured, but at the end of your post you say you do not even have SPF, which is it? The URL of your web application is irrelevant. The content of your mail may have been relevant before, but now you are blacklisted since Hotmail says Please contact your Internet service provider since part of their network is on our block list. Have you done that?

  • Hello @Law29, thanks for your answer. Yes I have issues with both. I have SPF for configured for my-domain.me and server.my-domain.me (system hostname) - This can be verified from the mail-tester report linked in my question. I wasn't sure if the URL of the web app needed SPF settings too hence the mention, thanks for clearing that up. I'm not concerned with fixing this for Outlook, just Google for now. – Ralph Mar 13 '16 at 15:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.