1

I use GPOs to push printers out to 10 different site, each site has its own policy. But for some reason all sites are getting the printers from site 1 when they login to terminal servers. They don't have access to the printers but they are still there.

I've tried disabling the GPO and removing it but the printers still show up. I created a new OU and set it to block inheritance ran gpresult and no policies were applied but the printers were there. I even checked to see if the printers are installed locally on the terminal servers and they are not.

I'm lost... I've went through every GPO we have to see if it was configured incorrectly somewhere. Nothing.

  • It's possible that once the policies were applied, the printers remained. Have you tried removing the printers, then running GPupdate to see if they return? It also could be part of a startup script, make sure you check those for both machine and user policies in each linked GPO. – Jonathan Piccirilli Mar 14 '16 at 16:50
  • Did you try RSOP? Try running a GP Modeling from a known broken User/Computer? What do these tell you. Also I don't believe that GP will remove the printers if you remove the policy. You may need to actually remove them either by GP or manually to test. – Nick Young Mar 14 '16 at 16:51
  • I'll remove the printers from the local computer then log on the terminal server. They still appear every time. – Stratag3m Mar 14 '16 at 17:19
  • Are you deploying these printers to the computer or the user? – joeqwerty Mar 14 '16 at 23:03
  • The printers are being applied to the user. – Stratag3m Mar 15 '16 at 11:37
2

You can use the gpresult command on a workstation to get a list of policies applied along with additional information such as

  • AD groups that the user and computer belongs to
  • GPOs that were filtered out and why
  • Which domain controller was used
  • etc

There is also a -v option for more verbose output

  • 1
    I would recommend using gpresult /h instead - it will create a more sophisticsted report with significantly more detail on settings applied and source GPOs defining them. And in OP's case, he would need to run gpresult on the terminal server, from within a user's session where he is seeing the incorrectly applied settings. – the-wabbit Mar 14 '16 at 20:02
  • Like I said in the original post... I did run a gpresult. No policies were being applied since the object was in a newly created OU with block inheritance. – Stratag3m Mar 15 '16 at 11:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.