6

I've successfully configured WinRM on my Hyper-V server to use HTTPS. I am able to connect to it and execute commands from my client PC by using the same local username and password on both (they are in a Workgroup) e.g. winrs -r:https://<server>:5986 dir.

However I can't figure out what address to specify in the "Connect to Server" dialog box in Hyper-V Manager to make it use HTTPS. By default it only tries to connect via HTTP which fails, since I do not want to add an insecure TrustedHosts exception. The error message itself states that I can use HTTPS instead of TrustedHosts.

1 Answer 1

0

Enable-PSRemoting Set-Item WSMan:\localhost\Client\TrustedHosts -Value "fqdn-of-hyper-v-host" Enable-WSManCredSSP -Role client -DelegateComputer "fqdn-of-hyper-v-host"

Computer Configuration > Administrative Templates > System > Credentials Delegation > Allow delegating fresh credentials with NTLM-only server authentication Click Enable and add wsman/fqdn-of-hyper-v-host.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.