1

I have a Dell XPS13(Win 10 Pro) and since we dont have wireless lan in the office i had to buy an external ethernet adapter (DA200).

The adapter works perfectly fine at home but it doesnt work at all in the office(not even the lights on the adapter are flashing) while i dont have any problems when connecting other computers to the ethernet socket.

However if i connect the adapter to an ethernet switch it works.

The laptop is part of a Win 2003 domain and on the server is a dhcp installed.

Is it possible that the adapter doesnt get an ip from the dhcp server?

Thanks in advance.

  • You say it doesn't work in the office, but that it works when you plug it into an Ethernet switch. What are you plugging into when it doesn't work? No lights generally means that they adapter doesn't "see" anything at the other end of the cable. That's long before operating systems or DHCP come into play, so you probably have a much lower-level (i.e., hardware) issue. – DarkMoon Mar 16 '16 at 6:29
  • ethernet socket on the wall -> cable -> adapter : doesnt work – factor77 Mar 16 '16 at 7:03
  • Ah, so still connected to the same switch, just not directly. When you test directly and it works, are you using the same switch port and patch cable as when it doesn't work, i.e., are you taking the opposite end of the patch lead from the switch, and plugged that into the adapter? If that's working, then the problem is in your wall wiring, or the patch lead coming out of the wall socket. If the same port and patch lead doesn't work, then it's either the port config, the port hardware, or that patch lead. – DarkMoon Mar 16 '16 at 7:18
  • Sorry just to make sure i didnt miss anything. wall-cable-switch-cable-adapter : works. wall-cable-adapter: doesnt work. used the same cable with switch, without switch and at home and i tried both ends of the cable. if its the port config or hardware how do i fix it and why does it work at home? thanks – factor77 Mar 16 '16 at 7:51
1

There is a chance that the network jack is wired wrong, and is acting as a crossover cable. Most modern NICs support auto MDIX, and can deal with this gracefully, but your dongle may not support this.

If you have a crossover network cable around, then put that in place between the dongle and the wall to see if that fixes it. If it does, you have wiring problems. If you do not have a crossover cable, then you'll need to verify that the terminations on both ends of the run are correct.

  • we have several and it doesn't work with any of them but thanks – factor77 Mar 16 '16 at 3:58
0

You may just have a bad (malfunctioning) adapter. I had a similar experience with a USB3 gigabit adapter I bought from Monoprice a while back.

The symptoms it displayed sound identical to what you're experiencing with yours. Basically, it was super picky about which switches/hubs it would actually work on. At home on an HP ProCurve in my office, no problem. At work directly connected to whatever switch was in the network closet, no joy. But throw a cheapo dumb switch in between it and the and the wall jack, and it works fine again. At first I chalked it up to a bad chipset. But a friend of mine got the same model and while his had its own issues, it worked where mine didn't and in some cases, vice-versa.

I ended up just buying a different model of adapter (this one) and it works great. I never did find any rhyme or reason regarding what caused it to work or not.

0

Typically, office network connections go like this:

Network /__\ Network /__\ Rack /__\  Wall /__\ Desk /__\ Network /__\ Network
Switch  \  /  Cable  \  / Port \  / Cable \  / Port \  /  Cable  \  / Adapter

Troubleshooting link-level problems usually lies in isolating each of these pieces and testing one by one. From what you've said, you've tested this as a whole, and tested switch <--> cable <--> adapter directly, bypassing the rack port, wall cabling, desk port, and far end cable. The first failed, the second succeeded. So the problem would lie in the pieces you've taken out. But I want to ensure that we've actually tested the same switch port and cable that was in the chain when it didn't work. Make sense?

If each piece tests OK, then the last thing to check would be the configuration of each. For instance, if you've hard-set the switch port to 100-Full and the adapter is trying to autonegotiate, it could cause problems. The ethernet standard (IIRC) says it shouldn't work, but vendors sometimes try to "help" and make it work anyway, leading to different results with different gear.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.