28

I get the following error when i am listing the updates.Server is currently registered with ULN. Although its a warning, i do not want the below message displayed when i am issuing yum command.i found out subscription-manager plugin is loaded. How to disable subscription-manager plugin??

Loaded plugins: downloadonly, product-id, rhnplugin, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.

6 Answers 6

49

There are two possible solutions:

  1. in the plugin configuration file, disable plugin:
    vim /etc/yum/pluginconf.d/subscription-manager.conf
    
    enabled=0
  1. Register to the satellite
7
  • does it work for RHEL 7.5 running on AWS ec2-instance as # subscription-manager register --auto-attach Registering to: subscription.rhsm.redhat.com:443/subscription Username: [email protected] Password: [email protected] cannot register with any organizations. Jul 17, 2018 at 11:44
  • Setting enabled=0 took care of this for me in Fedora 33. File was /etc/dnf/plugins/subscription-manager.conf on my system. Jan 10, 2021 at 20:21
  • For fresh installation of Fedora 32, the location of the configuration file is actually this: /etc/dnf/plugins/subscription-manager.conf
    – Dee'Kej
    Jan 18, 2021 at 11:18
  • Is there a command that can disable the plugin, as opposed to editing the file?
    – trebor
    Jul 19, 2021 at 19:33
  • The flags --noplugins or --disableplugin=plugin_name can be used to disable from command line (via red hat doc).
    – trebor
    Aug 2, 2021 at 21:49
9

At least in my case, RHEL 7.6, /etc/yum/pluginconf.d/subscription-manager.conf already had enabled=0.

/etc/yum/pluginconf.d/enabled_repos_upload.conf however, had enabled=1, and changing that to enabled=0 prevented the warning.

1
  • This worked for me - although subscription-manager.conf had enabled=1, setting it to zero had no effect on the warning message. enabled_repos_upload.conf enabled=0 suppressed the warning. Dec 30, 2019 at 4:02
6

To do this via the yum command line use --disableplugin subscription-manager. This method is good for scripting.

The following example will not print "not registered" message:

# yum --disableplugin subscription-manager list installed | head -3
Loaded plugins: langpacks, product-id, search-disabled-repos
Installed Packages
GConf2.x86_64                         3.2.6-8.el7                @anaconda/7.5

And just to show you that not providing the flag will print the "not registered" message:

# yum  list installed | head -5
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
              : manager
This system is not registered with an entitlement server. You can use subscription-manager to register.
Installed Packages
GConf2.x86_64                         3.2.6-8.el7                @anaconda/7.5
1
  • This is much better than hand-jamming a config file. Thanks!
    – Josh M.
    May 3, 2023 at 21:53
3

For me, this was fixed after removing the subscription-manager:

sudo dnf remove subscription-manager

You can always re-install if necessary

3
  • This is the red hat recommended solution.
    – kai
    Aug 30, 2022 at 16:59
  • 1
    just noting that removing subscription-manager will trigger removal of other packages, which you might want (podman, ovirt, cockpit).
    – markhahn
    May 7, 2023 at 17:39
  • Even with this, I still get these message when running dnf commands: Failed loading plugin "upload-profile": No module named 'subscription_manager' Failed loading plugin "subscription-manager": No module named 'subscription_manager' Failed loading plugin "product-id": No module named 'subscription_manager'
    – Josh M.
    Jan 7 at 22:04
2

Disable/remove the subscription-manager yum plugin.

Check this link: https://access.redhat.com/documentation/en-us/red_hat_subscription_management/1/html/rhsm/repos-disable

6
  • Florin, Will removing subscription-manager rpm resolve the issue as well?
    – xrkr
    Mar 20, 2016 at 13:45
  • Probably yes :). Mar 20, 2016 at 14:13
  • 4
    link is not working Page Not Found Jul 17, 2018 at 11:46
  • Please update the link.
    – zygimantus
    Sep 13, 2018 at 17:00
  • 1
    Removing subscription-manager wanted to autoremove ovirt and cockpit, so not a good option in my case. Dec 30, 2019 at 4:04
1

A few years have passed, yum has been replaced by dnf (but they seem to have made sure that command line parsing hasn't been broken too badly).

FWIW, dnf still produces the same error message, but it can be told to omit them with the --quiet switch. Chances aren't bad that this also works for yum.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .