Am using AWS windows EC2 instance. I set the inbound rules in the machine to open all ports for public access. I installed IIS, and XAMPP in 8080 port.

Now I could use 123.234.345.456 to open IIS and 123.234.345.456:8080 to open XAMPP. No problems so far.

Now I installed Telerik Sitefinity project manager. It created a dynamic port 14356 but when I use 123.234.345.456:14356 it says site can't be reached. I tried reinstalling application and reusing the port with XAMPP and all works. But whatever port that Sitefinity Project Manager uses (it is dynamic per start) it never works.

But in the RDP I can access all these ports like

localhost:14356 //Or any port created by Sitefinity
  • What is the output of netstat -na | grep 14356 (or the port the APP is running)? – Diamant Mar 20 '16 at 18:36

From your description, I suspect your application is listening only on localhost ( and this why it is not accessible externally. You can find it out yourself by running:

netstat -na | grep 14356

In that case you will need to change the applications configuration so that it listens to all or on the ip address reachable externally ( or 123.234.345.456:14356)

It turns out that you are running a trial version and it is meant to be run only on localhost.

Use a free trial version for any of the editions.

Sitefinity trial versions are for evaluation purposes only. You can run a trial only on local host. After the trial expires, the website redirects to the Sitefinity Activate a license page.

Ref: http://docs.sitefinity.com/create-projects

  • This is my netstat extract: [::1]:80, [::1]:8080, – Thamilan Mar 21 '16 at 0:37
  • 1
    @Thamizhan, As I have suspected, the application is listening only on local ip ( Are you running a trial version? – Diamant Mar 22 '16 at 11:02
  • Yes, it (sitefinity) is trial version. So how can I make IP visible? – Thamilan Mar 22 '16 at 12:23
  • 1
    I guess, you cant. The trial version is meant to be run only on localhost. docs.sitefinity.com/create-projects – Diamant Mar 22 '16 at 12:26
  • oh bad! But isn't there any option for IP visibility? – Thamilan Mar 22 '16 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.