1

My environment is Windows Server 2012 R2, IIS 8, Active Directory, and a file share. IIS, AD, and the file share are all separate VMs.

I have a website, www.example.com, set up in IIS. The application pool identity is set up as the AD user IUSR_example, which has "full control" permissions on the folder containing the site files. The site files are on the file share, which IIS references via UNC path.

In general, the site works in that it can serve up PHP, ASP.Net, and ASP Classic pages, and the code can even create new files.

However, I am having a problem that seems specific to PHP exec(). I've tried calling whoami, dir, and ffmpeg, and I get nothing returned from them. Using Sysinternals Procmon I have confirmed that the executable never starts.

Weirdly enough, I am able to make the exact same calls with ASP Classic (using WScript.Shell), and it works perfectly. I am also able to get PHP exec() working when the scripts are NOT running over the UNC path.

Here's what I've tried/found:

  • When using ASP, procmon reports that w3wp.exe spawns a cmd.exe process, which in turn spawns conhost.exe and (for example) ffmpeg.exe. The output file from ffmpeg successfully appears.
  • When using PHP, procmon reports that w3wp.exe spawns a php-cgi.exe process, which in turn creates a cmd.exe and a conhost.exe. A thread for ffmpeg.exe never appears.
  • cmd.exe is invoked with a command line that looks like this: cmd.exe /c ""--the command to be executed--""
  • The command line for the cmd.exe process is exactly the same for both ASP Classic and PHP.
  • In Procmon, the user is always reported as IUSR_example
  • I've tried adding 2>&1 to the end of the command
  • I've tried giving the IUSR to the "Replace Process-level Token" right
  • I've tried turning off FastCGI impersonation and switching between "NamedPipe" and "TCP" under Process Model > Advanced Settings
  • There are no errors in the PHP error log
  • There are no errors in any of the Windows Event logs

Note that this is not specific to ffmpeg. Any other use of exec() also fails. Also, I would prefer not to use WScript.Shell from within PHP because eventually we will be using WordPress plugins that rely on exec().

How can I further troubleshoot this?

1

As suggested by user "pajoye" over at bugs.php.net, using proc_open() allowed me to successfully execute commands. This in turn allowed me to use procmon to discover the difference between the way exec() and proc_open() work. Long story short, I would call this a core bug in PHP running on Windows when the PHP scripts are on a network share. Here are the key details:

  • exec() defaults the current working directory to the path of the PHP script, which in my case is a UNC path.
  • cmd.exe does not allow you do have a UNC path as the current working directory, and cmd.exe claims that it will revert to the Windows folder.
  • Although cmd.exe continues to execute and conhost.exe is spawned, the original working directory still causes some sort of problem, and the desired executable is never started.

So a simple workaround is to chdir() to a local directory before calling exec(). However, there are a lot of WordPress plugins that rely on exec(), so in my opinion exec() should be agnostic to whether the PHP script is running on a share. I will ask about whether a fix for this can be included in a future release.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.