-1

I'm trying to add a secondary dns to my dedicated ovh server.

From the control panel, it says that i need to create first a txt dns record with value xxxxx and subdomain ownercheck and then continue with wizard.

I've created the txt record using opendkim in this way:

opendkim-genkey -t -s xxxxxxxx -d ownercheck.mydomain.com

it generates me the .key and .txt

into .txt there is something like:

xxxxxxxx._domainkey IN  TXT ( "v=DKIM1; k=rsa; t=y; "
      "p=LONGKEY" )  ; ----- DKIM key xxxxxxxx for ownercheck.mydomain.com

I've edited this changing in:

"v=xxxxxxxx;p=LONGKEY"

and added as txt domain and i continue wizard, but unfortunately, ovh says me:

First we need to verify you are the owner of this domain. To do so, please add a TXT field on your DNS zone for the domain mydomain.com, with the subdomain 'ownercheck' and the following value: 'xxxxxxxx'. Once done and your zone reloaded, try again (you don't need to wait for DNS propagation).

Where I'm wrong?

2

You don't need dkim for these. You are supposed to add just a TXT record (like A or CNAME record). It would look something like this:

subdomain IN TXT "xxxxxxxx"

You will need to edit your domain's nameserver zone file for this and exact procedure depneds on your provider.

  • I've used dkim because I used it into the configuration of a mail server. That was the first time I create a txt record. Can you please detail how can i solve? Where I can find the domain's nameserver zone file? – JackTurky Mar 22 '16 at 20:37
  • DKIM and SPF should be separate TXT records. Domain ownership verification (this is your case) will require another, separate TXT record in DNS. – blaughw Mar 22 '16 at 20:57
  • DKIM and SPF are actually in another TXT. but.. how can i create a txt record for this case? – JackTurky Mar 22 '16 at 20:59
  • @JackTurky, check at your domain registrar's control panel. Your nameservers are listed there. If it is also by ovh then check the nameserver settings there. – Diamant Mar 22 '16 at 21:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.