0

I am running pureftp in docker container as non-root user file_app.

Here is the permission I assigned

chown -R file_app:file_app /etc/pure-ftpd
chown -R file_app:file_app /etc/ssl/private
chown -R file_app:file_app /var/log/pure-ftp
chown -R file_app:file_app /usr/share/lintian/overrides/pure-ftpd
chown -R file_app:file_app /usr/share/nginx # FTP HOME DIR

When I try to start /usr/sbin/pure-ftpd as user file_app, I get this error

Unable to start a standalone server: Permission denied

When I start as root, everything works

How to run pure-ftpd as non-root user?

  • You might need to change the Bind line in your /etc/pure-ftpd to listen on a port which doesn't require root privileges, e.g. Bind 127.0.0.1,2121. – Castaglia Mar 24 '16 at 4:02
  • Yes! it works after adding the parameter --bind=0.0.0.0,2121 – Mr.Wang from Next Door Mar 24 '16 at 4:27
  • Excellent. I've added that as an answer, rather than just as a comment, if you'd like to accept it. – Castaglia Mar 24 '16 at 4:46
1

You might need to change the Bind line in your /etc/pure-ftpd config file to listen on a port which doesn't require root privileges, e.g.:

Bind 127.0.0.1,2121

Hope this helps!

  • Also the pureftp should be compiled with --with-nonroot parameter – Mr.Wang from Next Door Mar 24 '16 at 5:20

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.