0

I have installed Windows Server 2008_R2 as a virtual guest operating system on my Centos-6.5 (the host). I also want to install the remote desktop feature, so that each user connecting to the win server see his/her desktop.

I followed the instructions from howtogeek and installed the licenses per user. Please see the picture below.

enter image description here

However, all users see one desktop which is shared! I want that each user see the login page and then he/she enters his/her credentials.

Any idea for that?

UPDATE1

Please see the picture below which shows a test. The left window is a vnc connection to the centos host which is running the windows server. The two right windows are the remote desktops from my laptop to the windows server. As I said before, I enabled the remote desktop feature from the virtualbox (server:3389). Please note that, as soon as I open the remote destktop application and enter server:3389, I see the administrator's desktop.

enter image description here

  • Can you clarify what you mean by "desktop?" – pat o. Mar 24 '16 at 12:23
  • Each user should see its own desktop (my documents, ...) – mahmood Mar 24 '16 at 12:52
  • What evidence are you seeing that leads you to believe that users are seeing the same desktop? – pat o. Mar 24 '16 at 13:14
  • Please see the updated post – mahmood Mar 24 '16 at 13:48
0

It appears you are logging in as Administrator on the server for both connections.

Each person will need its own user account on the remote desktop server.

The guide you referenced explains how you need to grant permission to each user (or a group) to be able to login.

  • Please note that I defined two users in the windows server. Problem is, as soon as I open the remote desktop and enter server:3389 and hit enter, I see the currently logged in user (here admin). It doesn't ask me which user you want to log in – mahmood Mar 24 '16 at 13:56
  • Regarding the last line of your reply, what is the next step after granting the permissions? – mahmood Mar 24 '16 at 14:18
  • The credentials are being saved. On the Remote Desktop Connection screen, if you drop down the "Options" section you should see the ability to change the username. – pat o. Mar 24 '16 at 15:25
  • No, I tried with a user name. Quickly I see the admin's dsktop – mahmood Mar 24 '16 at 17:13
  • Make sure you don't have any credentials saved by going to Control Panel \ Credential Manager. – pat o. Mar 24 '16 at 17:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.