5

PS: I seem to have solved this issue by adding all my domains to $mydestinations. I still do not understand why virtual_alias_maps seems to be ignored when looking for valid mydestinations.

After updating postfix, it started rejecting emails from external domains to my virtual domains (managed by Virtualmin / Webmin) on the server. My virtual domains in turn just forward these messages to gmail.

Mar 26 13:48:08 CentOS-72-64-minimal postfix/smtpd[10252]: connect from nm3-vm8.bullet.mail.gq1.yahoo.com[98.136.218.151]
Mar 26 13:48:08 CentOS-72-64-minimal postfix/smtpd[10252]: NOQUEUE: reject: RCPT from nm3-vm8.bullet.mail.gq1.yahoo.com[98.136.218.151]: 454 4.7.1 <[email protected]>: Relay access denied; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<nm3-vm8.bullet.mail.gq1.yahoo.com>
Mar 26 13:48:09 CentOS-72-64-minimal postfix/smtpd[10252]: disconnect from nm3-vm8.bullet.mail.gq1.yahoo.com[98.136.218.151]

I understand based on these issues (all related)

that this error is due to defer_unauth_destination default postfix setting.

However, I have a working virtual_alias_maps, but this map seems to be ignored by postfix as [email protected] is present in there and is set to forward to [email protected].

Here is my postconf -n

[root@host ~]# postconf -n
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
data_directory = /var/lib/postfix
debug_peer_level = 2
debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin ddd $daemon_directory/$process_name $process_id & sleep 5
html_directory = no
inet_protocols = all
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
newaliases_path = /usr/bin/newaliases.postfix
readme_directory = /usr/share/doc/postfix-2.10.1/README_FILES
sample_directory = /usr/share/doc/postfix-2.10.1/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
unknown_local_recipient_reject_code = 550
virtual_alias_maps = hash:/etc/postfix/virtual

Would you have any tips what I need to do to get this working?

2 Answers 2

3

In your postconf listing, I see virtual_alias_maps but I don't see virtual_alias_domains Try adding it as shown below.

virtual_alias_domains = MY-DOMAIN-ON-SERVER.com
2
  • Thx. Based on the docs at postfix.org/ADDRESS_CLASS_README.html#virtual_alias_class, "The default value is $virtual_alias_maps for Postfix 1.1 compatibility." So that should be ok.
    – giorgio79
    Commented Mar 26, 2016 at 15:54
  • To fix the error, I just had to add the domain name of my server to mydestination variable in /etc/postfix/main.cf.
    – baptx
    Commented Dec 1, 2017 at 18:54
0

I found the same error message. I could solve it in a similar way to baptx's, but in my case I had to add the IP address of the remote server which is trying to use your postfix relay under the mynetworks parameter in the configuration file /etc/postfix/main.cf

mynetworks = 172.16.x.x/32

Restart postfix service and it should work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .